SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
438 Posts
Discussion Starter · #1 ·
I drove the R today in the slush and snow. Started getting a hard vibration and the sound like a brake lathe running from underneath. Mighty scary. I would have said its a bearing locking up any other time. Thoughts?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,896 Posts
Have you removed your resonator? It rubs on the drive shaft and makes that sound.
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #3 ·
I haven't. Sounds bad. Destroys driveshaft over time I'm guessing? Muffler shop style thing?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,896 Posts
Yep, it will. I had mine removed for $40 at a local shop. Exhaust will also sound better at 4000+ RPM :D
Also, theres a bracket under the car thats gotten the name EBOD or Exhaust Bracket Of Death, something hits that thing, it will get pushed into the exhaust, pushes the driveshaft and f*cks up your entire drive line. Have them remove that.

http://forums.swedespeed.com/showth...ure-on-the-R&p=1984705&viewfull=1#post1984705
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #6 · (Edited)
Understood. I had to use the backup snow vehicle. If you think s60r maintenance is expensive?



Camo gangster wagon wins the hurtful maintenance bill smackdown.

Dog is a fan though...




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,896 Posts
I love G wagons! What year is that?

Sent from my HTC One_M8 using Tapatalk
 

·
Registered
Joined
·
438 Posts
Discussion Starter · #8 ·
It's an 05. This is its first snow in my ownership and it's pretty epic. In at 2ft or so of snow, and it's punching through good.


Sent from my iPhone using Tapatalk
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top