SwedeSpeed - Volvo Performance Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
203 Posts
Discussion Starter · #1 ·
This probably got covered so many times but I can't get the right answer. But my question is through the rpms at wide open throttle, is boost suppose to hold? Mines shoots to 6 drops to 4 sometimes 3. when it shifts shoots to 6 then drops. I have a 09 s60 SE 2.5f fwd a/t with 66k. eurosporttuning intake system. And just replace plugs with ngk. Could it be the tcv or cbv.
 

·
Registered
Joined
·
187 Posts
The boost levels do seem low. I seem to remember hitting peaks of 8-10 prior to getting a tune. The pressure does drop a bit as you get into the 5K+ RPMs but 3 PSI seems way low. The TCV would be a good place start, but you may want to check all of your pipes and connectors for for leaks. Start from the turbo, over to the intercooler and then over to the throttle body intake. A mirror and a flashlight may help and you may want to unsecure some of the hold downs so you can pull and twist some of the pipes and feel if anything is obviously loose. Also: reseat the electrical connectors to the 2 turbo controls. (PM me if you want a TCV, I've got about 4 of them!)

Some history of others boost mysteries: thread:

My mysterious turbo boost issues disappeared and have not returned in many months.
 

·
Registered
Joined
·
4,640 Posts
Yeah that's too low for even a non tuned LPT car, you should hit 8psi and hold at least 6psi till shift. I'd also suggest starting with the TCV as they are the most common source of problems aside from an actual leak. Just check for loose clamps or tears in the couplers and if that's all good order up a new TCV for $60 and give it a shot. If you have access to VIDA you might be able to see stored conditions that relate to low flow at the TCV.
 

·
Registered
Joined
·
203 Posts
Discussion Starter · #4 ·
See I figured something was wrong. Would you recommend using the other leading brands or oem is best? How would I gain access to VIDA is that a programmer?
 

·
Registered
Joined
·
203 Posts
Discussion Starter · #5 ·
I'm dumb ya I don't have access to either. I wish people in my area had volvos haha
 

·
Registered
Joined
·
4,640 Posts
Either OEM or Snabb would be fine, Snabb might last longer but either is better than a broken one. Pretty sure Twowheeling offered to send an extra OEM to you in an above post, maybe just try anothet used OEM or newer than yours, if it improves you can either get a new OEM or Snabb unit.
 

·
Registered
Joined
·
4,640 Posts
Depends on which IPD valve as they have recently started selling a newer unit with a design essentially the same as Snabb and Phuzz but for $30 more, LOL! And there older style unit wasn't very good at all really, most people had problems with them or at least very short service lifes.

I'd recommend the Snabb one as I am currently using it and it seems to be working as it should, costs about $60 and looks cool to boot.
 

·
Registered
Joined
·
203 Posts
Discussion Starter · #13 ·
Oooo kay this weekend it will be ordered!!! Hopefully doesn't fail like people use to say but it is a new design....
 

·
Registered
Joined
·
203 Posts
Discussion Starter · #14 ·
I had made a thread about when I cold start the.turbo makes a weird noise till warmed up. it will start qauking like a duck when you rev it itle quak faster. But when its warmed up its gone. Its not my exhaust bolts either!
 

·
Registered
Joined
·
877 Posts
I had made a thread about when I cold start the.turbo makes a weird noise till warmed up. it will start qauking like a duck when you rev it itle quak faster. But when its warmed up its gone. Its not my exhaust bolts either!
Well I wouldnt advise you to rev the engine until it is warmed up anyway. But I think a video would help everyone understand better what it is exactly your hearing
 
1 - 16 of 16 Posts
Top