SwedeSpeed - Volvo Performance Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
594 Posts
Discussion Starter · #1 ·
so i finally got my boost gauge and i'm about ready to install it. just to make sure i don't blow anything up i want to confirm a few things with you guys.

1. Where did you guys tap the 12v wire into? The Fuse box? I don't want to tap into my head unit or take it apart.

2. Also i tap into the hose that is under fuel injectors right? it is to the left of the intake box if i remove it.

3. How should i test the gauge to make sure that it is reading the correct numbers?

Thanks for your help!

PS: its a 2005 R and the gauge is the vdo one from ipd.
 

·
Registered
Joined
·
3,319 Posts
Sounds like you're all set.

To check if working and if you're stock and you routed the hose well and no kinks, you should full boost at WOT around 13.8psi-15, maybe a little higher for some cars - whatever the reason (at WOT, watch the gauge, if it starts dropping off, you may have a boost leak). When idling in neutral at a stop, you should have negative 18-20 (vacuum, hfgs).
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #4 ·
fuse box under the dash? which number?
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #6 ·
Ccm? I'm looking to tap into the fuse Box on the side by the door. Just don't know which one to tap into
 

·
Registered
Joined
·
2,192 Posts
Climate control module, you know below the radio? 05+ have fuses in the dash near the door that are always on, so if you tap a fuse there your boost gauge will always be lit even when the car is off. You'll have to tap a fuse in the fuse box underneath the dash by the pedals. I chose the DRL fuse.
 

·
Registered
Joined
·
1,396 Posts
I tapped in the side panel on my 04. 05+ may be different. it worked well. I had to sort out which fuse to tie to to get the light on and off with the key.
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #9 · (Edited)
okay i have it installed, but not all the way because i'm probably getting a different air hose, the one from ipd did not satisfy me. The install of the boost gauge went well, when the car is on and in park the boost gauge reads from -5 to -20....but when i am driving the boost gauge doesn't even go above 0....pretty sure it is not normal.....could i have installed the gauge wrong? all the plugs and such seem very tight.


this might be a better one...


the O on the gauge is at "11 o'clock" on the boost gauge.
 

·
Registered
Joined
·
145 Posts
okay i have it installed, but not all the way because i'm probably getting a different air hose, the one from ipd did not satisfy me. The install of the boost gauge went well, when the car is on and in park the boost gauge reads from -5 to -20....but when i am driving the boost gauge doesn't even go above 0....pretty sure it is not normal.....could i have installed the gauge wrong? all the plugs and such seem very tight.


this might be a better one...


the O on the gauge is at "11 o'clock" on the boost gauge.

by driving, you mean WOT right? What's it read during WOT?
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #12 ·
it's just regular driving, i tapped into the air hose under the injectors. what's wot?
 

·
Registered
Joined
·
145 Posts
it's just regular driving, i tapped into the air hose under the injectors. what's wot?
press gas pedal to floor whilst on a road.

What's the boost gauge read during above state?
 

·
Registered
Joined
·
103 Posts
WOT=Wide Open Throttle
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #16 ·

the highest i touched was 4.5 and that was like for a split second.......damn
 

·
Registered
Joined
·
3,319 Posts

the highest i touched was 4.5 and that was like for a split second.......damn
I watched your video twice, once in regular screen and once in full screen - you're lucky you got 4.5, it looks like you never even went above 40mph. Get a video of your boost gauge on the HIGHWAY and doing full throttle (it seems like your car is an auto). The fact that I see a good negative tells me you don't have any pinched lines and the boost guage does seem functionally correct. But until we see you going 50-60 *safely accelerating at WOT in 4th gear* and see what the boost reading is then. Then we can maybe help more, like a TCV issue, boost leak, etc.
 

·
Registered
Joined
·
594 Posts
Discussion Starter · #19 ·
I watched your video twice, once in regular screen and once in full screen - you're lucky you got 4.5, it looks like you never even went above 40mph. Get a video of your boost gauge on the HIGHWAY and doing full throttle (it seems like your car is an auto). The fact that I see a good negative tells me you don't have any pinched lines and the boost guage does seem functionally correct. But until we see you going 50-60 *safely accelerating at WOT in 4th gear* and see what the boost reading is then. Then we can maybe help more, like a TCV issue, boost leak, etc.
car is at the shop atm, i will record when i get it back, thanks for your help!
 
1 - 19 of 19 Posts
Top