SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 47 Posts

·
Registered
Joined
·
277 Posts
Discussion Starter · #1 ·
I just purchased a Motorola IHF1000 for my 2005 S60, which is the same unit Volvo sells for 10x as much and was wondering about the install. I have seen a couple posts talking about a wire harness so it will work with the head unit. Can anyone point me in the right direction as to that part so I don't have to attempt to splice into the unit? And any install tips would be greatly appreciated.

Thanks.
 

·
Registered
Joined
·
4,678 Posts
I just purchased a Motorola IHF1000 for my 2005 S60, which is the same unit Volvo sells for 10x as much and was wondering about the install. I have seen a couple posts talking about a wire harness so it will work with the head unit. Can anyone point me in the right direction as to that part so I don't have to attempt to splice into the unit? And any install tips would be greatly appreciated.

Thanks.
Go to the dealer and purchase the correct wiring harness, that will be the only way you can connect the unit to the HU. Though the wiring harness isn't really that cheap, maybe call up John at Boston Volvo parts department.
 

·
Registered
Joined
·
138 Posts
If you find out what part number the harness is please let us know. I'm thinking of doing the same if I am brave enough to try the install.
 

·
Registered
Joined
·
138 Posts
Also where did you buy the motorola unit and do you mind sharing how much it was? I see you can get the IHF1000 for as low as $79.99 at J&R or Buy.com but there are no package contents listed. I wonder if it includes the tape like the Volvo kit...although not really a big deal for 1/2 the cost.
 

·
Registered
Joined
·
277 Posts
Discussion Starter · #8 ·
I got the IHF1000 new on ebay for $55. Got lucky and found a new one from a private seller. There isn't any tape but I'm not too concerned about it. Here are some pics of what came in the box. It has a speaker that I will not use and I assume the Volvo wire harness will plug into the blue control box.



 

·
Registered
Joined
·
138 Posts
Thanks for the photos. Looks like the microphone is black in this kit. I think the Volvo one matches the grey plastic interior but not sure. I'm very interested to know if the harness you ordered works and how you decide to hook it up. I've decided I really want to do this (in order to curb my recent cravings for a new car) and the $150 total cost is much better than Volvo OEM. The cheapest I could find the Volvo kit is $319 at Boston Volvo but I haven't searched too much.

Have you seen the Volvo OEM install instructions? The images/drawings are awful but it gives you an idea of how they recommend you hook it up. One thing I note they recommend is installing a new safety clip in the A pillar...not sure why. Anyone know this? The instructions can be download somewhere or I have the pdf and can email it. I wonder where you can buy foam tape...
 

·
Registered
Joined
·
21,340 Posts
Thanks for the photos. Looks like the microphone is black in this kit. I think the Volvo one matches the grey plastic interior but not sure. I'm very interested to know if the harness you ordered works and how you decide to hook it up. I've decided I really want to do this (in order to curb my recent cravings for a new car) and the $150 total cost is much better than Volvo OEM. The cheapest I could find the Volvo kit is $319 at Boston Volvo but I haven't searched too much.

Have you seen the Volvo OEM install instructions? The images/drawings are awful but it gives you an idea of how they recommend you hook it up. One thing I note they recommend is installing a new safety clip in the A pillar...not sure why. Anyone know this? The instructions can be download somewhere or I have the pdf and can email it. I wonder where you can buy foam tape...
The Volvo kit includes the same unit above, and the mic. is black.

I think that the Volvo instructions are pretty comprehensive, but that's just me.

As for the clip on the A-Pillar, see my post here: http://forums.swedespeed.com/showth...-Hookup....not-56K-friendly&highlight=install Look at the very end of the first post / beginning of the second post in the thread.

The safety clip that holds the a-pillar on in the event of airbag deployment is extremely difficult to get off and return on unless you've seen it apart before. The instructions recommend cutting the clip and simply putting a new one on. You can see in the pictures that there are two tabs that go into two slots, and they only come out when the clip is rotated 90 degrees. I didn't show it in the picture, but when the clip is aligned with the a-pillar as it is in the first pic, it's locked in place and the top of the pillar can only deploy about 1". When you rotate the clip, the tabs on the clip line up with the slots on the cover and the slots on the pillar, and it will disengage from both sides.

Don't be terribly afraid to pull the pillar trim hard to pop it off. AFter all, it's designed to stay in on the event of an airbag explosion and not get blown off into your face, so that clip is stout.

As far as the BT install goes, the hardest thing is removing the CCM and HU. The CCM can be a PITA to take off...I've done it about 1/2 dozen times and, on my car at least, sometimes it comes right off and sometimes it takes like 20 minutes of wiggling and pulling to get it to pop off. Once you have that off, the rest is pretty easy, although you may need to root around inside the wiring looms that are foam taped together to find the right connection points for the wiring harness.
 

·
Registered
Joined
·
138 Posts
The Volvo kit includes the same unit above, and the mic. is black.

I think that the Volvo instructions are pretty comprehensive, but that's just me.

As for the clip on the A-Pillar, see my post here: http://forums.swedespeed.com/showth...-Hookup....not-56K-friendly&highlight=install Look at the very end of the first post / beginning of the second post in the thread.

The safety clip that holds the a-pillar on in the event of airbag deployment is extremely difficult to get off and return on unless you've seen it apart before. The instructions recommend cutting the clip and simply putting a new one on. You can see in the pictures that there are two tabs that go into two slots, and they only come out when the clip is rotated 90 degrees. I didn't show it in the picture, but when the clip is aligned with the a-pillar as it is in the first pic, it's locked in place and the top of the pillar can only deploy about 1". When you rotate the clip, the tabs on the clip line up with the slots on the cover and the slots on the pillar, and it will disengage from both sides.

Don't be terribly afraid to pull the pillar trim hard to pop it off. AFter all, it's designed to stay in on the event of an airbag explosion and not get blown off into your face, so that clip is stout.

As far as the BT install goes, the hardest thing is removing the CCM and HU. The CCM can be a PITA to take off...I've done it about 1/2 dozen times and, on my car at least, sometimes it comes right off and sometimes it takes like 20 minutes of wiggling and pulling to get it to pop off. Once you have that off, the rest is pretty easy, although you may need to root around inside the wiring looms that are foam taped together to find the right connection points for the wiring harness.
Oh I think the Volvo instructions are fairly comprehensive; its just sometimes hard to tell in those drawings what exactly they're doing. Still better than fumbling in the dark. I probably wouldn't attempt it otherwise. I just read a bit of your IMIV install post and will look at it again at home tonight (not all photos load at work...firewall *grumble*). Sorry to go OT but I've noticed background whine from my iMIV lately clearly from engine interference...I installed mine straight to the RTI a year ago so not sure if I just didn't notice the whine before or the cable has been damaged. Do you have any interference?

So with regard to the safety clip, are you recommending that we can remove and reinstall it without too much trouble? As long as you know where it catches that is.

Finally, sorry to sound like a newb but is CCM the panel around the gear shift lever? I may have been a SS member for a while but I don't log on often. I've never taken the HU out on my S60 but I did an ipod adapter install on my S70 and took the HU in an out of it and our 1st gen C70 often (lots of bad HUs)...which is obviously easier than the S60 but still I'm optimistic. I'm more worried about removing the glove box, pillar trim and roof liner since I've never done that. I've taken off my door panels before...is this easier or harder?
 

·
Registered
Joined
·
21,340 Posts
Twice I have had whine issues with my iMIV. LOUD. Both times it was connecting the Sirius power while the car was already up and running. Whatever "surge" freaked out the iMIV. What fixed it was re-loading the firmware. Dunno why, but it did.

CCM = Climate Control Module. This is kind of a PITA to get off, harder than door panel. Reason why (and I'm quoting -01 to -04 here) is that it's held in by 2 torx screws below the pen holder, then attaches to the HU by metal clips. in order to get them to separate, you need to pull the CCM out at the bottom and wiggle it up, down and around to get the clips to release. The other side of the metal clip attaches to a plastic piece on the CCM and they're easy to break. My CCM no longer sits flush on one edge.

As far as the A-pillar clip goes, have at it. I doubt you'll break it (take no responsibility here!). Just pop the top edge off, find that clip with your finger, and try to spin it. You'll know when it comes loose.
 

·
Registered
Joined
·
138 Posts
I've only noticed the whine in my iMIV when I've got the volume cranked but the song is at a quiet part. Mine increases with engine rev. Of course once I heard it I now notice it all the time. I installed my iMIV on top of the RTI and ran the cable behind the trunk liner to the rear seat passthru then under the rear seat and straight across the drive shaft tunnel above the carpet with the cable running up between the console and the passenger seat. I chose this since I mount my iphone using a Pro-Clip mount and holder to the right of the shifter. I've meant to go back and pull the cable through the rear door sill molding and under the passenger seat but clearly that didn't happen. I wonder if I should reinstall the firmware...the first version I put on last year kept raising the nav screen everytime I put the car in reverse. Since I don't have a backup camera that drove me crazy so I finally reset the firmware to a different version earlier this year. Maybe that's my problem? Or I wonder if the cable is touching some metal in the seat...

I'll have to revisit the install instructions with regard to the CCM. I'm not picturing in my mind why I would need to remove it but I'm at the office now. Thanks for your help I'll post followup questions if I move forward with BT install. Want to hear how it goes for capsfan69 first!
 

·
Registered
Joined
·
933 Posts
Anyone looking for a brand new set?
I have bought one for my 06 S60, but I haven't had the time to install and there's a whole list of things I rather do first (aka sport kit painted, tinting windows, have my car detailed/buffed) and would rather sell it for what I paid for from a seller who retired from the dealership and had extra parts. I honor the don't ask-don't tell policy. haha
Let me know if anyone wants everything, including the Volvo harness, EVERYTHING NEW in bag/package.
 

·
Registered
Joined
·
42 Posts
Anyone looking for a brand new set?
I have bought one for my 06 S60, but I haven't had the time to install and there's a whole list of things I rather do first (aka sport kit painted, tinting windows, have my car detailed/buffed) and would rather sell it for what I paid for from a seller who retired from the dealership and had extra parts. I honor the don't ask-don't tell policy. haha
Let me know if anyone wants everything, including the Volvo harness, EVERYTHING NEW in bag/package.
PM sent
 

·
Registered
Joined
·
277 Posts
Discussion Starter · #16 · (Edited)
New goodies arrived today!



I did a "dry" run (without fishing all the wires) and it worked perfect!! Can't wait to get it really installed. As you can see the install kit comes with the safety clip but no foam sticky tape. Anyone know where I can pick some up?
 

·
Registered
Joined
·
138 Posts
New goodies arrived today!



I did a "dry" run (without fishing all the wires) and it worked perfect!! Can't wait to get it really installed. As you can see the install kit comes with the safety clip but no foam sticky tape. Anyone know where I can pick some up?
AWESOME! Take lots of pictures if you can...I'll be the next one to install but may take me a few weeks.
 

·
Registered
Joined
·
42 Posts
New goodies arrived today!



I did a "dry" run (without fishing all the wires) and it worked perfect!! Can't wait to get it really installed. As you can see the install kit comes with the safety clip but no foam sticky tape. Anyone know where I can pick some up?
Hobby store, Marshall's, Michael's?
 

·
Registered
Joined
·
4,678 Posts
1 - 20 of 47 Posts
Top