SwedeSpeed - Volvo Performance Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
408 Posts
Discussion Starter · #1 ·
{sorry for the cross post for those that read VS}

Well here they are, I got the A/C panal finished this week just in time for burgerball. Sorry to all the people who attended who didnt get to see it in person, its hard to show cause it has to be night out in order to see anything. Its still not finished. Im getting some needle lights cause they arnt quite as bright as I would like them to be, and a few LEDs need adjusting, but its almost done. I would tell anyone who wants to do this not to try, its taken almost a year from TONS of trial and error. I think I am the first to have done a full LED conversion in blue with red needles. Well here they are:



And heres one of my car:



And an updated shot of my engine:

 

·
Registered
Joined
·
636 Posts
Re: Blue LED full interior done (SDSUpaintballplayer)

Looks Great...........If I can get to do that to my car, itll just be the cluster..

Awesome job!
 

·
Registered
Joined
·
2,720 Posts
Re: Blue LED full interior done (1sciroccofahrer)

let us know when you start getting headaches after driving your car


Unless its really just looks that bright
 

·
Registered
Joined
·
2,720 Posts
Re: (SDSUpaintballplayer)

Quote, originally posted by SDSUpaintballplayer »
its REALLY just the exposure time, its no where NEAR that bright in person

oh ok so well done...how long did it take?
 

·
Registered
Joined
·
90 Posts
Re: Blue LED full interior done (info2x)

that looks wicked. i managed to convert my instrument cluster to all red rather easily, but what you got there just puts it to shame, nice job http://********************/smile/emthup.gif
 

·
Registered
Joined
·
1,447 Posts
Re: Blue LED full interior done (95854turbo)

Man, that is BRILLIANT! http://********************/smile/emthup.gif
 

·
Registered
Joined
·
248 Posts
Re: (greenvolvopower)

Awesome work! I want to fit only my instrument cluster with bright white LED's. Very honda-ish I know. Where did you get your LEDs for the instrument cluster? Im looking for the standard plug and play wedge base. I've got W5W bulbs in my cluster now, made it a lot brighter with no noticeable side effects from over a year of use. One more question... why is your boost gauge reading zero with the engine on? It was one of the first things I noticed. Thanks! http://********************/smile/emthup.gif
 

·
Registered
Joined
·
408 Posts
Discussion Starter · #17 ·
most my bulbs were purchased from autolumination.com. Look for the 194 bulbs. My boost gauge has been acting funny, turns off and on at random, im replacing it with a aftermarket one very soon (its sitting next to me). Thanks for all your comments guys.
 
1 - 17 of 17 Posts
Top