SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
265 Posts
Discussion Starter · #1 ·
Well my left side BLIS is out yet again.. But that's easy compared to this odd issue..

Headlights Dim when normal cruising, Brighten when accelerating, which Wasnt a huge bother.. Until I tried to turn the wheels at a stop.. Major DIMMING and RPMS dropped forcing the car to catch up..

I guess back to the dealer.. Again.. Alternator? Anyone else have this issue?
 

·
Registered
Joined
·
1,837 Posts
Well my left side BLIS is out yet again.. But that's easy compared to this odd issue..

Headlights Dim when normal cruising, Brighten when accelerating, which Wasnt a huge bother.. Until I tried to turn the wheels at a stop.. Major DIMMING and RPMS dropped forcing the car to catch up..

I guess back to the dealer.. Again.. Alternator? Anyone else have this issue?
My lights dim at standstill when I turn the wheel. Not a lot be noticeable. It's been doing that from day one and is not a bother. The RPM does not change though.
It might be some voltage regulator problem and not the alternator.
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #3 ·
My lights dim at standstill when I turn the wheel. Not a lot be noticeable. It's been doing that from day one and is not a bother. The RPM does not change though.
It might be some voltage regulator problem and not the alternator.
Should not be doing that - Mine does it when accelerating as well.. RPM'S Noticeably drop when turning the wheel.. Like a massive power drain.. All cars have a tiny bit of drag from turning the wheel but it shouldent starve the engine to the point of rpm's dropping..
 

·
Registered
Joined
·
4,185 Posts
You have electric or electric-hydraulic power steering -- the pump is NOT connected to the engine by belt. When at idle, you'll get a momentary dimming of the headlights as the pump kicks in and the alternator/voltage regulator catch up to the high draw. But you should not see that at highway.

Weak battery, bad ground, weak/dying alternator or voltage regulator, or an issue in the power steering causing abnormally high current draw.

Yes, get to the dealer ASAP. And provide details once fixed.
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #5 ·
You have electric or electric-hydraulic power steering -- the pump is NOT connected to the engine by belt. When at idle, you'll get a momentary dimming of the headlights as the pump kicks in and the alternator/voltage regulator catch up to the high draw. But you should not see that at highway.

Weak battery, bad ground, weak/dying alternator or voltage regulator, or an issue in the power steering causing abnormally high current draw.

Yes, get to the dealer ASAP. And provide details once fixed.
Yeah it goes in friday - So on the road at cruise (50 mph) its fine.. Then accelerate - the lights brighten, as the RPMS drop they go back .. I mean the brightness is noticeable, abnormal imo..

I tested it again last night ..

Complete Stop -

Wheel left all the way - RPMS Drop from 700-400 (Lights Dim) and then it catches back up. If I move it back then forth it repeats.

Wheel right half way - Lights Dim and a slight RPM Drop ( maybe 100 ) then it catches back up.

No Gauge dimming but the interior overhead lights Definitely slightly dim.

Pretty annoyed - Car has 13,200 mi on it.. :(
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #6 ·
Update on this - Oh gosh where do I start...

On the way to the dealer I was on the freeway at about 80mph when a work truck ahead of me dropped some metal drive on ramps and wouldn't you know it.. I ran right over them.. Well that destroyed my Front RIM, Tire, and threw the car out of alignment.. Also got lovely CEL . AWD Warning light, TPMS Warning.. the whole sheeebang... wonderful.. CHP had to stop traffic to get the metal out of the freeway and 2 other cars fell victim to the plates.

So its been at the dealer since the 20th of Nov.. Luckily CHP was able to catch up to the guy from my description and write him a ticket and my insurance is taking care of it all..

Either way, expensive repair.. 1,000 for the tire/rim alone..

As for the electrical issue.. They FIRST tried the old "No Trouble found"... Then I told them to drive it till its warm first then see and wouldn't ya know it.. They noticed.. Severe power increase on accel/decrease off accel and RPM dip at idle.. They have been looking for the issue for a few days and are stumped.. BLIS needs 3 sensors to repair so that should be easy...

So yeah.. They have been very good to me so far.. Hope they fix the issue..

 

·
Registered
Joined
·
1,318 Posts
My lights dim at standstill when I turn the wheel. Not a lot be noticeable. It's been doing that from day one and is not a bother. The RPM does not change though.
It might be some voltage regulator problem and not the alternator.
I second that, mine has been doing that for 3 years now (2013 S60)
 

·
Registered
Joined
·
265 Posts
Discussion Starter · #8 · (Edited)
OK and shes back in my hands..

Dealer report:

Headlights - CONFIRMED Brightening/Dimming at speed... NOT Normal.. Also not normal CONFIRMED dipping RPMS when turning wheel at a stop (Dimming for a sec is normal, RPM Drop is not..) Battery was found to be culprit. Was not putting out enough power to power all systems. Replaced Battery, and doubled checked system. Problem resolved.

BLIS - Rear Cameras faulty - Tech said it was odd, it wasn't throwing any codes which he found strange but was completely dead? Reset entire system, replaced camera - plugged camera in - fixed, replugged old sensor in threw a code.. He was boggled? Either way fixed now, he thinks it might have be a symptom of the battery issue.

Haldex - Code said excessive vibration/pressure from Front Right - (Damage area) - to avoid damage the system disabled itself and went into FWD mode. System inspected and reset when new tire and rim installed and not reporting working no issues.

Rim - Simple replacement.. MSRP on that rim was over 450$ .. Highway robbery, but its my insurance that paid so.. oh well..

Tire - 240$??? Again, highway robbery...

Whole car inspected and flashed new software updates for BLIS and some other random things.

Either way all fixed.. Kudos to Niello Volvo (Sacramento) for getting it all ship shape and good communication.

B
 
1 - 8 of 8 Posts
Top