SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I am having some issues with a reduced engine performance warning. It only happens when I hit a big bump, going over railroad tracks in this case. When I went over the tracks or hit a big bump the warning will come up. The few times it has happened, the issue was fixed by restarting the car. Another note, my sister was using my car and ran it out of gas...it was sometime after this that I first started having the issue...is there a connection? O was thinking fuel filter issue.
 

·
Registered
Joined
·
4,640 Posts
Hi and welcome to the forums,

Sorry to hear about your problem but I think we might be able to help you out here. As I understand it your car is running okay but displays a message in the dash along the lines of "reduced engine performance" when you hit a large bump in the road? No other symptoms or lights on the dash like "check engine"? Does the car run any differently when the message is being displayed?

My hunch is that you have a short in your wiring somewhere that hit ground when bumped around and causes a temporary misfire. Most likely going to be one of the wires for the ignition coils under the top engine cover, common to have the wire looms become brittle and break, easy enough to pinch a wires when putting the cover back on. Might explain your issue but I would also reccomend making sure your battery terminals are tight and non corroded.

Maybe you could share some more information with us, like what year the car is. Also it's trim (2.3T, 2.4, 2.4T, 2.5T, R, etc...), mileage, any recent services or other problems.

Hope this helps,
NJGB
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
My car is a 2007 s60 2.5T and I just hit 100k miles. I haven't had any other issues yet...recently I had a check engine light on before all this started but I had the code checked out and I believe the issue was a worn out seal on the gas cap. As far as the warning light goes the only one that displays is the one say reduced engine performance., when this happens I loose pretty much all throttle response and when the car comes to a stop it starts idles bad like it wants to die. Like I said before all I have had to do thus far is turn the car off then back on.
 

·
Registered
Joined
·
4,640 Posts
Do you have access to VIDA/DiCE top check for any stored faults? If it's running like crap when it does this there will be stored info about what happens. I'd start by checking the condition of the wires under the upper engine cover like I mentioned.

EDIT - Might it also have something to do with the ETM, electronic throttle module, I wonder?
 
1 - 4 of 4 Posts
Top