SwedeSpeed - Volvo Performance Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
435 Posts
Discussion Starter · #1 ·
Hi all,
I've got my D5 Inscription since July and every time I start the car I get on the driver display the "safety belt overview"; it only goes away if I press the right driving wheel button. Have someone found a way to make the overview automatically go away? Or am I the only one that doesn't like pressing a button every time I start the car to have the display cleared? :)
Cheers massimo
 

·
Registered
Joined
·
435 Posts
Discussion Starter · #3 ·
Interesting, my car will move but will start beeping if one of the front seats senses someone in it without a fastened belt. I need to talk to my salesperson ... probably something that can be changed only in the shop...
 

·
Registered
Joined
·
435 Posts
Discussion Starter · #5 ·
Got you, mine *does* but the "belt overview" stays on and the car will start to produce annoying "bling"s if someone is not fastened. I wonder what it is like for other markets ...
 

·
Registered
Joined
·
541 Posts
Both my current cars have a warning sound that takes a long time to go away if the Driver and Passenger (if someone is in the seat) are not wearing their seat belts. I have not been in cars that won't drive if the seat belt is not fastened.

FYI- USA market
 

·
Registered
Joined
·
81 Posts
I have an 2015.5 XC60 loaner while waiting for my new vehicle - and it has a broken tire pressure sensor. As far as I can tell, because of that i can never get out of the tire pressure display. Point being that if the system is similar in the XC90, the display gets hung up on one thing if there is a feedback error, and it may be a bad sensor if it is staying up much longer than expected. But if you just don;t want to see it at all, I'd suspect there is no way around that : )
 

·
Registered
Joined
·
603 Posts
If Auto Parking Brake is activated the car won't move if the belt isn't fastened. And you can turn it off just by pressing the button on the armrest...

Sent from my iPhone using Tapatalk
I agree this most likely is the reason. You can go into your setting and take it off. I am guessing you have the auto setting set up for the parking break.
 

·
Registered
Joined
·
435 Posts
Discussion Starter · #10 ·
Just for me to understand, I don't have the "auto Parking Brake" enabled and the belt overview stays on the screen, no matter what, until I press the right steering wheel button. Anyone seeing this? Swiss Market car.
 

·
Registered
Joined
·
1,436 Posts
How long have you driven with the display still showing? Like it stays for an hour or do you always clear it right away?

Also I'm a bit confused- are you trying to drive without your seatbelt and it won't go away, or belts are fastened and it won't go away?

And finally, is it showing the seats with unbelted passengers in red, or another section, or no section but just won't go away?
 

·
Registered
Joined
·
435 Posts
Discussion Starter · #12 ·
How long have you driven with the display still showing? Like it stays for an hour or do you always clear it right away?

Also I'm a bit confused- are you trying to drive without your seatbelt and it won't go away, or belts are fastened and it won't go away?

And finally, is it showing the seats with unbelted passengers in red, or another section, or no section but just won't go away?
sorry for not being precise: I buckle up normally, the overview shows my seat with a nice black belt across it and I can drive. The overview stays on until I press the button on the wheel. It will not go away on its own.
 

·
Registered
Joined
·
1,436 Posts
Ah yeah that really doesn't seem right and I haven't experienced it. Do you have VOC working? I'd try unlocking and locking from there just to make sure no doors or tailgate are sending messages but beyond that I think this is probably a software update issue.
 
1 - 13 of 13 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top