SwedeSpeed - Volvo Performance Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
6,888 Posts
Discussion Starter · #1 ·
Hey guys,<P>How many of you have switched out your OEM batteries with aftermarket ones? I'm thinking of putting in an Optima red top. Also, granted that I know jack about batteries, how the heck do you read the labels? I tried looking for the batteries with the same specs but no luck. Can I get something that relatively close to it? Also, what spec can I get close to it? I know it has to be 12V and 120RC but what about the CCA? On the C70 it's 600CCA, but I can't find a red top with the number. TIA.<p>[This message has been edited by mike_c70 (edited 05-16-2002).]
 

·
Registered
Joined
·
6,564 Posts
Ack...forget about the Optima red top ( <IMG SRC="http://www.swedespeed.com/ubb/biggrin.gif"> even though I have a yellow top), just buy that Interstate off my hands. <P>Hmm...the shipping probably will cost more than the actual battery~! <IMG SRC="http://www.swedespeed.com/ubb/biggrin.gif">
 

·
Registered
Joined
·
6,888 Posts
Discussion Starter · #3 ·
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by The_one_n_only:<BR><B>Ack...forget about the Optima red top ( <IMG SRC="http://www.swedespeed.com/ubb/biggrin.gif"> even though I have a yellow top), just buy that Interstate off my hands. <P>Hmm...the shipping probably will cost more than the actual battery~! <IMG SRC="http://www.swedespeed.com/ubb/biggrin.gif"></B><HR></BLOCKQUOTE><P><BR>Kai, what are the specs on your yellow top? It's too late anyways, I just came back from the dealer to replace the battery. Had to dish out $150.00!!! <IMG SRC="http://www.swedespeed.com/ubb/mad.gif">
 

·
Registered
Joined
·
6,564 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by mike_c70:<BR><B> <BR>Kai, what are the specs on your yellow top? </B><HR></BLOCKQUOTE><P>I don't really know, and pretty much no way to check out. It's hidden under the trunk now. The audio guy made the decision for me on this one.<BR>
 

·
Registered
Joined
·
2,332 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by The_one_n_only:<BR><B> I don't really know, and pretty much no way to check out. It's hidden under the trunk now. The audio guy made the decision for me on this one.</B><HR></BLOCKQUOTE><P>you moved the battery to the trunk?<BR>so what did you put in place of all that extra space in the front??<P>isnt that hard to do? rewiring whatnot?<P>
 

·
Registered
Joined
·
2,331 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by The_one_n_only:<BR><B>...just buy that Interstate off my hands.</B><HR></BLOCKQUOTE><P>Hmmm, what are the specs? I need a battery for my 240.<P>
 

·
Registered
Joined
·
6,888 Posts
Discussion Starter · #7 ·
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by The_one_n_only:<BR><B> I don't really know, and pretty much no way to check out. It's hidden under the trunk now. The audio guy made the decision for me on this one.</B><HR></BLOCKQUOTE><P>Are you running dual batteries or is the yellow top solely for the audio system?<BR>
 

·
Registered
Joined
·
6,564 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by GShyneDM:<BR><B> you moved the battery to the trunk?<BR>so what did you put in place of all that extra space in the front??<P>isnt that hard to do? rewiring whatnot?<P></B><HR></BLOCKQUOTE><P>Check the other thread.."Dyno Pics" to get a closer look of my engine bay.<P>It wasn't the easiest to do, I'll say...I wouldn't suggest you to attempt doing that yourself if you've never done it before.
 

·
Registered
Joined
·
6,564 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by towerymt:<BR><B> Hmmm, what are the specs? I need a battery for my 240.<P></B><HR></BLOCKQUOTE><P>I'll check..how much u want it for?
 

·
Registered
Joined
·
6,564 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by mike_c70:<BR><B> Are you running dual batteries or is the yellow top solely for the audio system?</B><HR></BLOCKQUOTE><P>Nope, just one battery.
 

·
Registered
Joined
·
2,331 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by The_one_n_only:<BR><B> I'll check..how much u want it for?</B><HR></BLOCKQUOTE><P>Next to nothing. <IMG SRC="http://www.swedespeed.com/ubb/tongue.gif"> How long has it been sitting unused?<P>My battery works, but 1hr of playing the radio yesterday drained it enough so that my car wouldn't crank and I had to jump start it. I finally bought a set of jumper cables today, just in case.<P>
 
1 - 12 of 12 Posts
Top