SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
535 Posts
Discussion Starter · #1 ·
So it's been long enough. . . I've been wanting to get back into an R after selling my VR a while back and finally found my cheap ticket to do so.


This 2007 S60R was at a local repair shop and after stopping to talk to the shop owner, I mentioned that I wanted another R badly. He got me in contact with this cars owner, who wasn't keen to spend money to fix it. So long story short, I picked it up and gonna work to address some little issues here and there before I'll trust it on a long trip.


The main issue currently is that when you go WOT the message pops up "NO OIL PRESSURE, PLEASE STOP!". But under normal driving conditions it seems to be ok. Long term, it will probably need an oil pick up tube and the oil pan cleaned out, and then run some form of cleaner like seafoam in it just before oil changes. But even worst case, if it ends up needing an engine, I'm still in it for cheap enough I can throw a used 2.5 or 2.3 (AND MOAR BOOSTS) and not get my feelings hurt.

As some of you may recall, my friend Briggs got into making downpipes for the Rs for a while, but he recently accepted a new job working in a metal fab shop and doesn't do much side work anymore. Lucky for me. . . the second downpipe Briggs ever made was never installed, so of course I went ahead and installed it :)


While I can tell you this car is faster than my old VR due to it weighting less, I gotta admit, I miss the cargo space of the wagon badly!

Glad to be back on the forum and in the R community! :)
 

·
Registered
Joined
·
5,060 Posts
Welcome back!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
33 Posts
Welcome back into the fold friend!!!! And if you do need a new motor I say either contact me and I’ll possibly buy the motor for a build, or build it your self (sleeves, pistons, rods, everything lol)

Is it M66 or a trouble box?



Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,570 Posts
Welcome back!

As an SR owner who formerly owned a VR, I share that sentiment. When I'm driving my current R, I forget all about my old wagon though.
 

·
Registered
Joined
·
535 Posts
Discussion Starter · #8 ·
Thanks for the warm welcome back guys! I can honestly say I've missed this community!

Loving having an R again, BOOOOOOST!

Troubleshooting some issues with the car, found a DEM error when I ran VIDA. Need to troubleshoot further and see if its a failed DEM, DEM pressure sensor or pump. Looking forward to diving in!
 
1 - 8 of 8 Posts
Top