SwedeSpeed - Volvo Performance Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
When I back out of the drive way it sounds like I am scraping something on the bottom of my car. Sound seems to be rear driver side. Wheel bearing or tranny issue? Gonna probably dig into it on Monday but was hoping someone might be able to give me a clue or idea of what I might be looking for.

Sent from my moto e5 (XT1920DL) using Tapatalk
 

·
Registered
Joined
·
2,568 Posts
The model year of your 1800 would be useful information, as in rear drum brakes or disc brakes? On a drum it could be a problem with the shoes failing to retract. Wheel bearings usually give you a little advance notice if they are failing with an increase in noise. If you have drum rear brakes, the 1800 and Amazon share a lot of parts and I know that getting the rear drum off of an Amazon can have its challenges. You might want to do a little research on that topic.

If you have rear discs, some debris might have become trapped between the pad and the disc. Also, a really worn pad that is failing to retract or gets cocked sideways can make interesting noises. The shoes in the parking brake may also be failing to retract; but, its not obvious how that could happen.

If you don't have the service manual, get a copy here:

http://volvo1800pictures.com/sweden/Volvo_1800_dokumentation_main_page_en.php
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Thanks for the link. It's a 69s, or at least that's what the paperwork says. I have not pulled the wheel yet I am pretty sure they are drums. I like the idea it's just brakes rather than bearings or any other such nonsense.

Sent from my moto e5 (XT1920DL) using Tapatalk
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I believe it was just a stuck e brake. The bar was stuck, took a couple whacks of a mallet to reset it. I soaked it with penetrating oil and will work it back and forth the loosen it up, and hopefully that's all it will take.

Sent from my moto e5 (XT1920DL) using Tapatalk
 
1 - 5 of 5 Posts
Top