SwedeSpeed - Volvo Performance Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there,

Im new into the volvo world, only had japanese and italian cars.. But felt in love with the confort of a 2001 S60 T5, auto.
It looked like a good deal, 130.000km (about 80k miles), timing belt was done, car was in good shape..
I was aware of the AW55-50 problems, but there was no flaring, everything looked fine.
Drove about 500km this week and half (brought the car last week). Today, went to the parts store to buy Motul JW3309 spec oil to flush the tranny, but on my way back, shifting from 2nd to 3th, it kept on 2nd (shows 3th on the dashboard), and suddently (after 2-3 seconds) with a bang went to 4th, and safe mode.. turned on and off, same thing, doesnt go into 3rd.. skips to 4th with a soft bang..
Just flushed the tranny with new oil (14liter total until it was nice and red), but it stays the same :(
Is it worth to change de solenoids / valve body? Might it be the B4 cover?
Or just give up and find a replacement transmission? :?

Managed to find a local one, from a crashed 55.000km 2003 XC70, reference AW55-50SN. Is it compatible?

Sorry about my poor english.
Thanks a lot, I would appreciate some help!
Pedro
 

·
Registered
Joined
·
133 Posts
Hi there,

Im new into the volvo world, only had japanese and italian cars.. But felt in love with the confort of a 2001 S60 T5, auto.
It looked like a good deal, 130.000km (about 80k miles), timing belt was done, car was in good shape..
I was aware of the AW55-50 problems, but there was no flaring, everything looked fine.
Drove about 500km this week and half (brought the car last week). Today, went to the parts store to buy Motul JW3309 spec oil to flush the tranny, but on my way back, shifting from 2nd to 3th, it kept on 2nd (shows 3th on the dashboard), and suddently (after 2-3 seconds) with a bang went to 4th, and safe mode.. turned on and off, same thing, doesnt go into 3rd.. skips to 4th with a soft bang..
Just flushed the tranny with new oil (14liter total until it was nice and red), but it stays the same :(
Is it worth to change de solenoids / valve body? Might it be the B4 cover?
Or just give up and find a replacement transmission? :?

Managed to find a local one, from a crashed 55.000km 2003 XC70, reference AW55-50SN. Is it compatible?

Sorry about my poor english.
Thanks a lot, I would appreciate some help!
Pedro
Hi, I suggest to overhaul is better if you want to use it for long time. I have experienced to overhaul transmission twice. First time it took about 6-7 years before I did overhaul again for second time. Swap second hand cannot make sure how long will you face the problem. It might be soon or later.
 
1 - 2 of 2 Posts
Top