SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

Registered
Joined
1,692 Posts
Discussion Starter · #1 · (Edited)
I'm going to change the transmission oil in my S80 V8 2007 but I can't find where I'm supposed to connect my hose to the car, to let the transmission pump out the oil. Here is a picture of what it looks like if I remove the airbox, drivers side of the car behind the radiator. Circled in red are two hoses that come from the transmission, circled in yellow is the line that goes down and away somewhere but better matches the location at which it seems the author has connected the hose on his XC90.



I've bought the green clip at my dealer as well as some hose that seemed to fit the clip at my local hardware store, since the ipd kit was ridiculously crazy expensive to have shipped to Sweden.

So my question is: I can't find any hose with a green clip to remove and replace, so which hose exactly is it that I'm supposed to undo? And when I find it, do I just attach the hose to the radiator? Anyone with experience from having done this job? Do I need two people, one to e.g hold the hose in place or will it stay there you think?

Edit: did some digging on VIDA and the two lines in red are of course the one of interest but is it the upper or lower I should remove?
 

Registered
Joined
248 Posts
The hose in the yellow circle along with the other hose on the bottom with the metal clamp are coolant hoses. Unfortunately I don't remember which of the two in the red circle is the in and which is the out but those are the lines you want. Those green clips are for the xc90 and not the s80.
 

Registered
Joined
1,692 Posts
Discussion Starter · #4 ·
The hose in the yellow circle along with the other hose on the bottom with the metal clamp are coolant hoses. Unfortunately I don't remember which of the two in the red circle is the in and which is the out but those are the lines you want. Those green clips are for the xc90 and not the s80.
I know they changed some clip when I had Volvo do the last transmission flush so I was dead certain I had one of the green ones. Parts guy had a hard time finding it, I guess this is why, lol.

The top of the 2 hoses circled in red is the one to connect your hose to for pumping out the fluid.
Thanks. So I attach the hose to the radiator thing, not on the loose transmission fluid line?
 

Registered
Joined
1,325 Posts
Attach to the to the line. I f you want to attach to the radiator thing than disconnect the bottom hose. and attach to the thing there.
 

Registered
Joined
10 Posts
Hi, I want to do the same with mine S80. Can you tell me how to remove the line from the radiator? Squeeze and pull? Did you change the o-rings and clips? What size of the hose did you use? Thanks
 

Registered
Joined
1,692 Posts
Discussion Starter · #7 ·
Yep, squeeze it and pull it. I think I pressed on it to remove any tension, just in case. It felt like it was going to be much harder to remove than it turned out to be. I had a small plastic bottle underneath, but inside the engine bay, ready to catch old ATF dripping out. Not a lot but enough to make a minor mess.

Opening the fill plug was probably the trickiest thing with this whole job, or maybe I just had tools that were awkward to fit in the engine bay.

No, I didn't change any o-rings but that's because I forgot, I probably should've changed the level plug o-ring (small torx underneath the transmission).

I'm not sure what diameter hose I used but I think it was an 8 mm inner diameter, something like that.
 
1 - 7 of 7 Posts
Top