SwedeSpeed - Volvo Performance Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #1 ·
crap! hehhe<P>do i need to go to the dealer and get this fixed???<P> <IMG SRC="http://www.swedespeed.com/ubb/frown.gif"> or is there sumthing that i am not doing right. i pulled the lever all the way up, and only the seat will move back and fourth. the electrical slider wont roll back!! and its all the way foward! <IMG SRC="http://www.swedespeed.com/ubb/frown.gif"><P>anyone else encounter this problem?
 

·
Registered
Joined
·
6,888 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by GShyneDM:<BR><B>crap! hehhe<P>do i need to go to the dealer and get this fixed???<P> <IMG SRC="http://www.swedespeed.com/ubb/frown.gif"> or is there sumthing that i am not doing right. i pulled the lever all the way up, and only the seat will move back and fourth. the electrical slider wont roll back!! and its all the way foward! <IMG SRC="http://www.swedespeed.com/ubb/frown.gif"><P>anyone else encounter this problem?</B><HR></BLOCKQUOTE><P><BR>It's either one of the servos blew or the wire connecting the lever to the motors. I had the latter happen to me. I think in the older models there is some plastic thing that connects the lever to the motors. Well, mine broke and they replaced it with a new metal wire. Have the dealer check both out. But before you do that, check under the seat to make sure the connectors are plugged in.<BR>
 

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #4 ·
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by The_one_n_only:<BR><B>Does it just happen to the passenger side?</B><HR></BLOCKQUOTE><P>well.. so far.. <IMG SRC="http://www.swedespeed.com/ubb/frown.gif"> heheh i dunno if it has happened to the drivers side<BR>
 

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #5 ·
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by mike_c70:<BR><B> <BR>It's either one of the servos blew or the wire connecting the lever to the motors. I had the latter happen to me. I think in the older models there is some plastic thing that connects the lever to the motors. Well, mine broke and they replaced it with a new metal wire. Have the dealer check both out. But before you do that, check under the seat to make sure the connectors are plugged in.</B><HR></BLOCKQUOTE><P>hrmm.. ok i will check that. and if i cant find anything.. off to the dealer perhaps on tuesday :p thanks<P>
 

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #6 ·
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by mike_c70:<BR><B> <BR>It's either one of the servos blew or the wire connecting the lever to the motors. I had the latter happen to me. I think in the older models there is some plastic thing that connects the lever to the motors. Well, mine broke and they replaced it with a new metal wire. Have the dealer check both out. But before you do that, check under the seat to make sure the connectors are plugged in.</B><HR></BLOCKQUOTE><P><BR>i checked and things are connected. when i pull the switch to move the seat back.. i hear an electrical ticking, kinda like a spark is there.. but thing isnt moving. maybe i have the first thing. one Question.. is this covered on the Warranty?? I mean.. the car is 1998 model... but this isnt a Wear/tear problem... is it? i've heard this happen quite often..<BR>
 

·
Registered
Joined
·
79 Posts
C70 ELECTRIC SEATS= P.O.S<BR>I hate them with passion. (no one is allowed to get in the back seat of my car anymore...well the ladies are but that's it <IMG SRC="http://www.swedespeed.com/ubb/wink.gif"><BR>Ok this is what you need to know, and what to do....VOLVO's dumb idea for electric seats caused stupid errors...NOW there is a small spring about an inch long that makes the whole seat move..(this has happened to me alot.)<BR> The spring falls off or breaks, so the whole seat is stuck....<BR>WHAT TO DO: If you pull up on the slip that is kind of tucked on the side you can see some parts (if you are sitting in the seat on the drivers side it will be on the back left, VISA VERSA for the passenger)now you see a little crank thing that you can push UP an push DOWN, (it goes a little inside somewhere?) Well if you push it down inside the CRANK or lever thing....your seat should move...and if it is up it doesn't move....I hope yall can understand this.... i could take pictures sometime and post them if you want....HOPE THIS HELPS>..PICS LATER TO COME....----MATT
 

·
Super Moderator
Joined
·
39,289 Posts
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by C70 MATT:<BR><B>no one is allowed to get in the back seat of my car anymore...well the ladies are but that's it <IMG SRC="http://www.swedespeed.com/ubb/wink.gif"><BR></B><HR></BLOCKQUOTE><P>WHAT? What are the ladies doing in the...back seat? OK...I guess I will leave this alone! <IMG SRC="http://www.swedespeed.com/ubb/biggrin.gif"><P>Yannis<P>
 

·
Registered
Joined
·
2,332 Posts
Discussion Starter · #9 ·
<BLOCKQUOTE><font size="1" face="Verdana, Arial">quote:</font><HR>Originally posted by C70 MATT:<BR><B>C70 ELECTRIC SEATS= P.O.S<BR>I hate them with passion. (no one is allowed to get in the back seat of my car anymore...well the ladies are but that's it <IMG SRC="http://www.swedespeed.com/ubb/wink.gif"><BR>Ok this is what you need to know, and what to do....VOLVO's dumb idea for electric seats caused stupid errors...NOW there is a small spring about an inch long that makes the whole seat move..(this has happened to me alot.)<BR> The spring falls off or breaks, so the whole seat is stuck....<BR>WHAT TO DO: If you pull up on the slip that is kind of tucked on the side you can see some parts (if you are sitting in the seat on the drivers side it will be on the back left, VISA VERSA for the passenger)now you see a little crank thing that you can push UP an push DOWN, (it goes a little inside somewhere?) Well if you push it down inside the CRANK or lever thing....your seat should move...and if it is up it doesn't move....I hope yall can understand this.... i could take pictures sometime and post them if you want....HOPE THIS HELPS>..PICS LATER TO COME....----MATT</B><HR></BLOCKQUOTE><P>You hit the problem RIGHT on the nose! :p when i was snoopin around down there.. i noticed the loose spring.. but couldnt figure out where it went. now that you tell me there is sumthing it connects to..i found the thing the spring is supposed to connect to. well turns out the cheap plastic connector is broken, which is why the spring was loosE!! grr.. did someone say that volvo will replace this with a metal wire?? perhaps there is some way i can secure the spring so it doesnt fall off again after they repair it. i better get it fixed in my drivers seat too. this is covered under warranty no? grr.. thanks a bunch for your help <IMG SRC="http://www.swedespeed.com/ubb/smile.gif">
 

·
Registered
Joined
·
79 Posts
IMAGE STATION SUCKS<P>[This message has been edited by C70 MATT (edited 05-26-2002).]<BR>HEY I"M GONNA SEND YOU AN EMAIL WITH THE PIC....NO ONE WILL HOST MY IMAGE!<p>[This message has been edited by C70 MATT (edited 05-26-2002).]
 
1 - 10 of 10 Posts
Top