SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 21 Posts

· Registered
Joined
·
331 Posts
Discussion Starter · #3 ·
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (Kirb)

Strange ... Talking with Johann about this .... I did the swap between stock and BMC tree times for good measure and with the stock back it... no CEL.... put the VBMC in CEL in a few minutes



What Evolve software do you have ..... different than 93 Gold ?
 

· Registered
Joined
·
171 Posts
My ECU is stock.
I dropped in a K&N and threw a CEL after a week. Changed it back and reset ECU and no CEL. A few months later I tried dropping the K&N back in and the CEL went on faster than I could pull out of the garage.
 

· Registered
Joined
·
2,003 Posts
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (blf)

I'm getting ready to drop in Evlove's CAI system from the blue car. I am running 92 octane, so I'm not sure which programming they gave me. I will let you know if I throw a CEL.
 

· Registered
Joined
·
345 Posts
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (blf)

Quote, originally posted by blf »
05's seem to be a little different animals as well. May try one again

I have an 05 with SvR/Evolve/Powerchip ECU/DP, TME exhaust and BMC filter for a little over 6 months (~7000 miles), no CEL. I run Sunoco 94 year round.

Bill
 

· Registered
Joined
·
63,013 Posts
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (05s60r)

Quote, originally posted by 05s60r »


I run Sunoco 94 year round.

Not for much longer. Sunoco 94, all but GONE, and WILL be gone everywhere by May 15th
 

· Registered
Joined
·
345 Posts
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (JRL)

Quote, originally posted by JRL »
Not for much longer. Sunoco 94, all but GONE, and WILL be gone everywhere by May 15th

Fortunately there is a station nearby that sell 100. The lowest I paid is $5.50, I think it is up to $8 now.
 

· Registered
Joined
·
331 Posts
Discussion Starter · #11 ·
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (05s60r)

Quote, originally posted by 05s60r »
I have an 05 with SvR/Evolve/Powerchip ECU/DP, TME exhaust and BMC filter for a little over 6 months (~7000 miles), no CEL. I run Sunoco 94 year round.

Bill

Again....weird cars


Maybe the JR (blue) is a little different than the BMC?
 

· Registered
Joined
·
3,392 Posts
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (blf)

Quote, originally posted by blf »

What Evolve software do you have ..... different than 93 Gold ?
latest version of 91 Octane for 3.5" DP
 

· Registered
Joined
·
3,392 Posts
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (frankhoffy)

Quote, originally posted by frankhoffy »
I'm getting ready to drop in Evlove's CAI system from the blue car. I am running 92 octane, so I'm not sure which programming they gave me. I will let you know if I throw a CEL.
Please dyno before and after to see how much gain you get...
 

· Registered
Joined
·
2,003 Posts
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (Kirb)

Quote, originally posted by Kirb »
Please dyno before and after to see how much gain you get...

Can't dyno the CAI because I need air flowing into the system. I was thinking about picking up a GTech RR. Coordinating all of this is going to be a major pain in the butt though. Hope you guys appreciate it if I pull it off somehow.

Really, Evolve should be the ones supplying the numbers...
 

· Registered
Joined
·
331 Posts
Discussion Starter · #15 ·
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (Kirb)

Maybe the newer tune accepts it
Quote, originally posted by Kirb »
latest version of 91 Octane for 3.5" DP
 

· Registered
Joined
·
331 Posts
Discussion Starter · #16 ·
Re: Anyone with EVOLVE ECU use a BMC/JR etc filter w/o a CEL? (blf)

Anyone with MY software upgrade ... no DP tune, just the 93 Gold from Evolve/Powerchips, not SVR or the 91 for the DP ........... with a BMC/JR and no cel......

Still not finding out ... jsut ordered a JR to try this all again...maybe take it to the dealer to see wha the code is......

Can it be something THAT problematic ? can I drive around with the CEL and not worry ... just throw my stock filter back in when I inspect?
 

· Registered
Joined
·
331 Posts
Discussion Starter · #17 ·
Re: (autoduel)

Quote, originally posted by autoduel »
My ECU is stock.
I dropped in a K&N and threw a CEL after a week. Changed it back and reset ECU and no CEL. A few months later I tried dropping the K&N back in and the CEL went on faster than I could pull out of the garage.

Did you resent with 6/23 with the new filter in ?.... maybe thats the ticket... the ecu must re learn new paramenter for higher airflow ?
 

· Registered
Joined
·
356 Posts
Re: (blf)

I have 2005 R with SvR/Evolve ECU, Evolve 3"DP & Exhaust, and BMC Filter.

I get the CEL all the freaking time. I've pulled fuses #6 and #23 about 4 times over the last 6 months to try to see if the CEL would go away. It would go away but only for 2-3 days. Then it comes back again.

So, for me, resetting the ECU by pulling fuses is not the solution.
 

· Registered
Joined
·
63,013 Posts
Re: (ArtVandelay0023)

Quote, originally posted by ArtVandelay0023 »
I have 2005 R with SvR/Evolve ECU, Evolve 3"DP & Exhaust, and BMC Filter.

I get the CEL all the freaking time. I've pulled fuses #6 and #23 about 4 times over the last 6 months to try to see if the CEL would go away. It would go away but only for 2-3 days. Then it comes back again.

.
Just put the stock air cleaner back in for a couple of weeks to see if that is definitely the problem
 

· Registered
Joined
·
331 Posts
Discussion Starter · #20 ·
Re: (ArtVandelay0023)

Quote, originally posted by ArtVandelay0023 »
I have 2005 R with SvR/Evolve ECU, Evolve 3"DP & Exhaust, and BMC Filter.

I get the CEL all the freaking time. I've pulled fuses #6 and #23 about 4 times over the last 6 months to try to see if the CEL would go away. It would go away but only for 2-3 days. Then it comes back again.

So, for me, resetting the ECU by pulling fuses is not the solution.

OK then ... Im not alone in this ...whats the deal? ... just ordered a JR...well see if its any different

Art --- do you know what the code is saying?.....any problems with performance or do you just ignore the light?
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top