SwedeSpeed - Volvo Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #1 ·
I did a bunch of stuff on our wagons today, and the last thing I went to do was swap out the fuel filters. I'd seen how easy this was, and was anxious to knock em both out. On both cars, I was able to get the quick-connect off on the in-port…but on both cars, the clip on the out-port was stuck. I monkeyed with it on my car for 20 minutes before hooking the in-port back up and moving on to my wife's car…only to find the same thing with hers! I didn't want to risk breaking them (looks like it's not an easily sourced part), so I thought I'd check and see if anyone has a trick? Would something like PB Blaster help with something like this?
 

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #3 ·
So it finally just came off? I can barely squeeze the clips. I think I'll hit it with PB blaster, let it sit, and hope for the best.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,411 Posts
Discussion Starter · #5 ·
That looks like a pretty slick little tool. I may try to glue some little "nubbins" to a pair of needle nose pliers to see if I can't fake the funk. I also didn't realize that you squeeze the front of that tab to unlock and the back to relock. Perhaps consciously focusing my efforts on the front will make a difference too. Thanks!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top