SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1,548 Posts
Discussion Starter · #1 ·
Just put in the Ion yellow PIAA bubls for the fog lights. It looks great.. when they work. The problem is I keep blowing the fuse, not right away but after an hour or two of using them. I went with 25A in there. It is a 55W and it seemed like people were not having issues with them. Something not right or should I use a higher fuse? Thanks.
 

·
Registered
Joined
·
1,422 Posts
Re: Anybody with PIAA fog light bulbs?? (xman03)

Quote, originally posted by xman03 »
Just put in the Ion yellow PIAA bubls for the fog lights. It looks great.. when they work. The problem is I keep blowing the fuse, not right away but after an hour or two of using them. I went with 25A in there. It is a 55W and it seemed like people were not having issues with them. Something not right or should I use a higher fuse? Thanks.

I am using the PIAA Extreme White Plus rated at 55W which draw about 4.5 amps. The foglight circuit is rated at 7.5A and should not be exceeded. Don't go with a higher fuse rating than recommended by Volvo - could create too much heat and destroy the wiring (or worse).
 

·
Registered
Joined
·
329 Posts
Re: Anybody with PIAA fog light bulbs?? (ZenZone)

I had been running Ion Yellows in my fogs as well. Like you said, worked great, but both bulbs burned out in less than a year. Haven't had fogs for a few months till I ordered new HID's. Not sure if it was just bad luck or what.
 

·
Registered
Joined
·
273 Posts
fyi as an avid piaa enthusiast, the piaa bulb life is very short. i bought a set of $9 japanese h3 yellow bulbs from ebay that have lasted for over 2 years. piaa bulbs only lasted me a couple of months. couldnt tell the difference in light intensity
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top