SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
422 Posts
Discussion Starter · #1 ·
OK guys, I have a problem here. My car leaks alot of water whenever I let it sit, and the other day I saw steam coming out from the grill.

I opened the hood, and saw coolant all over the place, the pipes and everything in the front of the engine, even on the cloth cover under the hood.

I refill my coolant resrvoir every couple weeks, which I believe is more than usual.

O ya, I popped my hood this morning, and saw some corrosion on those metal pipes by the hoses near the front of the hood.

Do you have any idea as to what I need to do? A leak possibly... replace a hose?

As always, Thanks
 

·
Registered
Joined
·
2,331 Posts
I don't have an 850 to look at, and I'm not that familiar with how the hoses are routed. However, I would suspect a split heater/radiator hose. When I broke a hose on my 240, I could see a small but steady stream of coolant dripping under the car. Perhaps you have a bad seal at the water pump and the coolant is hitting the belts and spraying it all over the engine bay? Clean the engine, find out where it's coming from, and fix it.
 

·
Registered
Joined
·
422 Posts
Discussion Starter · #4 ·
Thanks guys for the tips, this week isn't going too well for me.

O well, I'm starting a new post on O2 sensors... I have a problem with that too...

Anyways, I just bought some radiator stop leak stuff, and so long as I don't run my car up to the redline
, I'm OK, and it doesn't spit coolant all over the place. I found out that the radiator has a hole in it, so I hope this "radiator fix-leak" stuff doesn't kill it.

O well, good luck everyone
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top