SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
So the anti-skid warning showed up on my dash about a month ago and it didn't take me long to figure out that I didn't have AWD anymore. My ABS light is not on though. My mechanic is telling me it could be the BCM (BCM 0094.) I've been looking at Xemodex and a new module is $400. I just wanted to see what you guys thought before I go and spend money that might not need spending. I read some stuff on wheel speed sensors causing this but 3 out of the 4 of mine are new and the 4th I checked and there are no signs of wear. I didn't hit any potholes or anything either. I was just driving about about 30mph around a corner when the message showed. Since then it hasn't turned off and the code can't be cleared either. The angle gear is in good working condition as well. Any suggestions would be greatly appreciated. Thanks guys.
 

·
Registered
Joined
·
552 Posts
check your DEM temp/ pressure sensor

So the anti-skid warning showed up on my dash about a month ago and it didn't take me long to figure out that I didn't have AWD anymore. My ABS light is not on though. My mechanic is telling me it could be the BCM (BCM 0094.) I've been looking at Xemodex and a new module is $400. I just wanted to see what you guys thought before I go and spend money that might not need spending. I read some stuff on wheel speed sensors causing this but 3 out of the 4 of mine are new and the 4th I checked and there are no signs of wear. I didn't hit any potholes or anything either. I was just driving about about 30mph around a corner when the message showed. Since then it hasn't turned off and the code can't be cleared either. The angle gear is in good working condition as well. Any suggestions would be greatly appreciated. Thanks guys.
I had this happen on my MT SR w/ same symptoms and no ABS warning light - it was the DEM temp / pressure sensor. Just search this forum. No independent mechanic I spoke with knew jack**** about the ANTI SKID warning. So I went to dealer, had them pull codes. The BCM and DEM threw codes but the issue was the TP sensor in the DEM. You could roll the dice and swap the 111.00 part yourself. odds are typically 60/40 for the sensor not the DEM... If you do need to send the DEM to xemodex they actually replace the TP sensor anyway. Tough call... If this happened to me again and had no ABS issue I'd just get the part and risk the 111.00 which is what it will cost you to get a trained volvo tech w/ a clue to diagnose
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #4 ·
I had this happen on my MT SR w/ same symptoms and no ABS warning light - it was the DEM temp / pressure sensor. Just search this forum. No independent mechanic I spoke with knew jack**** about the ANTI SKID warning. So I went to dealer, had them pull codes. The BCM and DEM threw codes but the issue was the TP sensor in the DEM. You could roll the dice and swap the 111.00 part yourself. odds are typically 60/40 for the sensor not the DEM... If you do need to send the DEM to xemodex they actually replace the TP sensor anyway. Tough call... If this happened to me again and had no ABS issue I'd just get the part and risk the 111.00 which is what it will cost you to get a trained volvo tech w/ a clue to diagnose
Awesome, thanks for the help man. This has been killing me.
 
1 - 4 of 4 Posts
Top