SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Thanks in advance. I have a 2011 XC90 3.2 with the above issues. Anti skid off appeared first and then the other issues all came on shortly after. I have tried disconnecting the battery and replacing fuses.
After disconnecting the battery it will start and drive, but all the lights come back on as soon as I step on the brakes. Car will only drive in limp mode no speedometer or tachometer. It lurches when shifting into reverse and drive.
Occasionally, car won’t start or will idle roughly and die shortly after starting.
Battery is new. Scanner shows several faults with the CanBus.
Any suggestions where to start?
 

·
Registered
2008 XC90 3.2
Joined
·
1,455 Posts
What are the other issues? What lights are showing? A generic OBDII scanner will not be able to find the brake issues. You will need VIDA or a more extensive scanner tool such as an Autel.

Some preliminary thoughts:
ABS sensor - should still be able to drive, just DSTC off
Brake Pedal Position Sensor - power brakes may be affected which affects the DSTC, less brake pressure on the brakes (could be the reason for lurching)
No Speedo or Tach - I haven't had to deal with that. But could be a fuse to a relay.
You say the battery is new - did you use the correct procedure when installing the battery?

What helps is to know what other lights are showing and to get a good scan so connected systems can be identified. Any additional information.
 

·
Registered
Joined
·
579 Posts
I'd suspect that one of the individual wheel reluctor rings could be bad. It might help to clean them up by taking the rust off them. Way back when with a Mazda 626 that had been in an accident one of the reluctor rings cracked. It took them a long time to figure that one out.
 
1 - 3 of 3 Posts
Top