SwedeSpeed - Volvo Performance Forum banner
521 - 540 of 568 Posts

·
Registered
Volvo XC60 D5 R-Design 2012 Polestar (Aftermarket CarPlay & Front Camera)
Joined
·
298 Posts
Andy my system information info shows identical info to yours, and, aside from the MCU upgrade which took us to version 1.9.0 as you know - I also received a fresh copy of the ‘Software’ ie the ‘CIB_8818_5G V3.10.2.1223’ from Kremersino today. I had first tried the MCU 1.9.0 shared by Sumps - no joy. I then installed (presumably) same version MCU software, but that was sent to me by Kremersino - also no joy. I then installed the latest CIB software, taking note of any version changes appearing in System summary each time.

The CIB software I already had installed and the ‘latest’ CIB software did not show any software version change on system summary - but I noticed word changes in the depths of the Advanced settings - specifically the ‘learn keyboard’ (not the right term I’ll need to get to it tomorrow to describe it accurately) wording is different than before (unless I’ve gone nuts which is always possible!) - it now reads “VirKey Learn” as shown in pic below. This wording change was the reason I stated ‘different‘ - I didn’t have time to delve deeper but personally concluded one word change indicated a difference and therefore there may be other differences - no more than that at this time.
Ill try verify again the above observations & statements, always possible I’ve got this wrong.
hope that explains - happy to share software too as always.
cheers
Font Gadget Display device Rectangle Electronic device
 
  • Like
Reactions: andyaus33

·
Registered
Volvo XC60 D5 R-Design 2012 Polestar (Aftermarket CarPlay & Front Camera)
Joined
·
298 Posts
Here 2012 also working.
Hi Dubstar - just curious you mentioned aircon working on your 2012, but your signature says your is a 2013 - just wondering if you have a later car build than 2012 & possible reason it’s working? Really just mulling over potential differences that may cause aircon not to work for some?
Thanks
 

·
Registered
Joined
·
125 Posts
2012 xc60 the red headed bastard child of volvo…. no auto shifting in transmission sports mode like all the other years and strange compatibility issues when doing things like tft retrofit and this carplay display issue …
 

·
Registered
2014 V40 D4
Joined
·
31 Posts
I wonder if it's possible to do something similar with Android using Tasker.
Also just an update on this - I initially had no luck with making Tasker disconnect from the box, but I stumbled across a plugin called BlueTask that makes it work. I have my phone paired to both the Volvo BT (set to phone calls and contacts only in the phone BT settings) and the Box (set to phone calls only, no media or contacts). When you start the car, my phone actually connects to both at the same time, and then after 45 seconds I set Tasker (Via BlueTask) to disconnect from the iSmart Box (specifically select the "headset" profile in the BlueTask config), leaving the call audio only connected to the Volvo BT - have no issues using Google Assistant or making/reciving calls now, calls are automatically routed through the Volvo BT and everyone can hear me much clearer than when the call audio was routed through the iSmart box. Hope that helps anyone else dealing with the same issues using Android.
 

·
Registered
Volvo XC60 D5 R-Design 2012 Polestar (Aftermarket CarPlay & Front Camera)
Joined
·
298 Posts
Also just an update on this - I initially had no luck with making Tasker disconnect from the box, but I stumbled across a plugin called BlueTask that makes it work. I have my phone paired to both the Volvo BT (set to phone calls and contacts only in the phone BT settings) and the Box (set to phone calls only, no media or contacts). When you start the car, my phone actually connects to both at the same time, and then after 45 seconds I set Tasker (Via BlueTask) to disconnect from the iSmart Box (specifically select the "headset" profile in the BlueTask config), leaving the call audio only connected to the Volvo BT - have no issues using Google Assistant or making/reciving calls now, calls are automatically routed through the Volvo BT and everyone can hear me much clearer than when the call audio was routed through the iSmart box. Hope that helps anyone else dealing with the same issues using Android.
Great post thanks. Out of curiosity for your setup - is the audio set to go through Aux (CarPlay default for audio?) if so when you receive a call on car OEM BT does the audio punch through regardless? (I ask partly as I found somewhat unexpectedly that when mine is set to Aux Audio using CarPlay for audio - the cars OEM Nav audio instructions if navigating, still come through the cars audio - quite neat to run in background on those rare country trip occasions where no 3G/4G signal available so phone nav apps are somewhat constrained)
 

·
Registered
Volvo XC60 D5 R-Design 2012 Polestar (Aftermarket CarPlay & Front Camera)
Joined
·
298 Posts
2012 xc60 the red headed bastard child of volvo…. no auto shifting in transmission sports mode like all the other years and strange compatibility issues when doing things like tft retrofit and this carplay display issue …
I feel your pain 😂
 

·
Registered
2014 V40 D4
Joined
·
31 Posts
Is the audio set to go through Aux (CarPlay default for audio?) if so when you receive a call on car OEM BT does the audio punch through regardless?
Yeah audio is done through Android Auto & passed to the car via the USB Audio adapter (no AUX port in the v40 with high performance audio) - but to answer your question, yes the phone call audio punches through, but the key/steering wheel commands don't revert to OEM unless you switch out of CarPlay/AA (eg. clicking OK while the screen is on AA but the OEM BT is ringing won't answer the call like to does when not in AA, you still have to click answer in AA/CarPlay or hit the voice button on the wheel). I also unexpectedly discovered that traffic alert broadcasts (eg. when you go through the Burnley or Domain tunnels and there's a radio broadcast from CityLink about an accident) automatically override whatever audio source you have set and punch through over CarPlay/AA as well.
 

·
Registered
2016 Volvo XC60
Joined
·
65 Posts
Yeah audio is done through Android Auto & passed to the car via the USB Audio adapter (no AUX port in the v40 with high performance audio) - but to answer your question, yes the phone call audio punches through, but the key/steering wheel commands don't revert to OEM unless you switch out of CarPlay/AA (eg. clicking OK while the screen is on AA but the OEM BT is ringing won't answer the call like to does when not in AA, you still have to click answer in AA/CarPlay or hit the voice button on the wheel). I also unexpectedly discovered that traffic alert broadcasts (eg. when you go through the Burnley or Domain tunnels and there's a radio broadcast from CityLink about an accident) automatically override whatever audio source you have set and punch through over CarPlay/AA as well.
Hi
I run Carplay through a wired connection only and have wireless & Carplay bluetooth turned off.
If I have the Volvo OEM bluetooth connection enabled will the phone calls come through the Volvo system and not the Carplay system? I ask this question because the current audio quality through the Carplay system is ok but nowhere near as good as through the Volvo OEM bluetooth connection.
Also assume Siri on the Carplay unit will still work ok with this setup?
Cheers Andy
 

·
Registered
2012 S60 D5 R-Design
Joined
·
67 Posts
Hi Dubstar - just curious you mentioned aircon working on your 2012, but your signature says your is a 2013 - just wondering if you have a later car build than 2012 & possible reason it’s working? Really just mulling over potential differences that may cause aircon not to work for some?
Thanks
wow Never noticed. Typo.. sry car is from 2012 :)
 

·
Registered
2014 V40 D4
Joined
·
31 Posts
Hi
I run Carplay through a wired connection only and have wireless & Carplay bluetooth turned off.
If I have the Volvo OEM bluetooth connection enabled will the phone calls come through the Volvo system and not the Carplay system? I ask this question because the current audio quality through the Carplay system is ok but nowhere near as good as through the Volvo OEM bluetooth connection.
Also assume Siri on the Carplay unit will still work ok with this setup?
Cheers Andy
Hey mate, CarPlay and Android Auto behave a little differently with media audio, CarPlay will let you redirect the audio to another device, whereas in my experience AA will force the media audio through the headunit via the AA wifi/cable stream (so no bluetooth audio if you're connected via USB etc) - BUT as far as I understand, both AA & CarPlay treat call audio the same way, and that is that they both basically throw it to the car's integrated BT system, even on cars with factory fitted CarPlay, the call isn't transfered over the CarPlay WiFi or USB connection, but via BT only.
I'm actually unsure how CarPlay would behave without pairing the Bluetooth to the iSmart box and using only the USB CarPlay connection, as normally a step of setting up CarPlay or AA in a new car is paring with the car's bluetooth. I'm assuming it just forces a BT connection to the iSmart Box if another BT device isn't connected, which would explain your drop in call audio quality.
That's a very long message to say basically; if your iPhone is connected to the Volvo BT but only connected to the box via USB, I'd assume when a call is placed/comes in then it would just go through the Volvo BT. That's all educated guesses, ultimately you'd just have to try and see because I don't have an iPhone on hand to try and test to see how it works - otherwise the iOS shortcut posted earlier in the thread sounds like it'll solve your problem by flicking your phone back over to the OEM BT after establishing the CarPlay connection.
 

·
Registered
Joined
·
1,330 Posts
Discussion Starter · #532 ·
Also just an update on this - I initially had no luck with making Tasker disconnect from the box, but I stumbled across a plugin called BlueTask that makes it work. I have my phone paired to both the Volvo BT (set to phone calls and contacts only in the phone BT settings) and the Box (set to phone calls only, no media or contacts). When you start the car, my phone actually connects to both at the same time, and then after 45 seconds I set Tasker (Via BlueTask) to disconnect from the iSmart Box (specifically select the "headset" profile in the BlueTask config), leaving the call audio only connected to the Volvo BT - have no issues using Google Assistant or making/reciving calls now, calls are automatically routed through the Volvo BT and everyone can hear me much clearer than when the call audio was routed through the iSmart box. Hope that helps anyone else dealing with the same issues using Android.
Any chance you can post a screenshot of the Tasker / BlueTask actions/settings? Thanks.
 

·
Registered
Volvo XC60 D5 R-Design 2012 Polestar (Aftermarket CarPlay & Front Camera)
Joined
·
298 Posts
I too have heard back from Kremersino contact regarding aircon display (not working on my XC60 & some other):
“Thank you for your effort, all you done is correct.
After tested and feedback from customer, we realized the software fit for V60/S60 only at moment, AC data in each model is different. Since your model is XC60, the AC functions do not show in display.

We will test in local cars and add more models AC data, once get software for XC60 we will update you. Thank you”

Quick check with community - my recollection is most that have it working do have a V60/S60 but there are also some (?) XC60s got it working too, if you are one of these XC60 owners please confirm & what year & I’ll provide that feedback.
thanks
 
  • Like
Reactions: andyaus33

·
Registered
2016 Volvo XC60
Joined
·
65 Posts
I too have heard back from Kremersino contact regarding aircon display (not working on my XC60 & some other):
“Thank you for your effort, all you done is correct.
After tested and feedback from customer, we realized the software fit for V60/S60 only at moment, AC data in each model is different. Since your model is XC60, the AC functions do not show in display.

We will test in local cars and add more models AC data, once get software for XC60 we will update you. Thank you”

Quick check with community - my recollection is most that have it working do have a V60/S60 but there are also some (?) XC60s got it working too, if you are one of these XC60 owners please confirm & what year & I’ll provide that feedback.
thanks
Volvo XC60 2016.5 working
 

·
Registered
2016 Volvo XC60
Joined
·
65 Posts
Hey mate, CarPlay and Android Auto behave a little differently with media audio, CarPlay will let you redirect the audio to another device, whereas in my experience AA will force the media audio through the headunit via the AA wifi/cable stream (so no bluetooth audio if you're connected via USB etc) - BUT as far as I understand, both AA & CarPlay treat call audio the same way, and that is that they both basically throw it to the car's integrated BT system, even on cars with factory fitted CarPlay, the call isn't transfered over the CarPlay WiFi or USB connection, but via BT only.
I'm actually unsure how CarPlay would behave without pairing the Bluetooth to the iSmart box and using only the USB CarPlay connection, as normally a step of setting up CarPlay or AA in a new car is paring with the car's bluetooth. I'm assuming it just forces a BT connection to the iSmart Box if another BT device isn't connected, which would explain your drop in call audio quality.
That's a very long message to say basically; if your iPhone is connected to the Volvo BT but only connected to the box via USB, I'd assume when a call is placed/comes in then it would just go through the Volvo BT. That's all educated guesses, ultimately you'd just have to try and see because I don't have an iPhone on hand to try and test to see how it works - otherwise the iOS shortcut posted earlier in the thread sounds like it'll solve your problem by flicking your phone back over to the OEM BT after establishing the CarPlay connection.
Hi
Thanks for the feedback, I tried with both Volvo OEM Bluetooth and Kremersino Bluetooth and neither will connect when Carplay has wired USB connection.
Kremersino unit displays a message when you try and enable Bluetooth on the unit "Carplay is linked. Bluetooth is disable". I also checked the Volvo OEM Bluetooth status when wired Carplay was active and it says "Not Connected",
The Kremersino unit must disable all Bluetooth when you have a wired USB connection using Carplay.
Will try wireless connection and see if phone audio quality improves.
Cheers
 

·
Registered
Volvo XC60 D5 R-Design 2012 Polestar (Aftermarket CarPlay & Front Camera)
Joined
·
298 Posts
Will try wireless connection and see if phone audio quality improves.
Tried this out of interest on mine (just to explore audio quality & try understand how it may work better). Curious how you went - my experience, not using wired, and pairing both CarPlay & OEM Bluetooth was that when car turned on, due (probably) to OEM BT starting up first - it connects first (and only) BT connection, but CarPlay doesn’t start at all - it prompts to connect BT. If I then manually initiate BT connection on iPhone, to CarPlay it too connects - then CarPlay starts up & then (as part of start up) switches over to Wifi & disconnects the BT to iPhone connection. That’s as far as I went, more to try but seems not to work?
 
  • Like
Reactions: andyaus33
521 - 540 of 568 Posts
Top