SwedeSpeed - Volvo Performance Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
8,786 Posts
Discussion Starter · #1 ·
Anyone seen issues with Android Auto on a device running Android 9? I took a trip with AA running the entire drive with no hiccups. On the drive back, the phone would get disconnected and Sensus would say connect compatible device (or something like that). Sometimes unplugging and plugging would work, other times not. Never had this issue with Android 8 device.
 

·
Registered
Joined
·
373 Posts
I see that error sometimes on Android 8. I have a very short USB cable and I fit my phone into the center console so it could be due to pressure on the cable compromising the connection. When I unplug/plug the issue is resolved.
 

·
Registered
Joined
·
8,786 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
311 Posts
Anyone seen issues with Android Auto on a device running Android 9? I took a trip with AA running the entire drive with no hiccups. On the drive back, the phone would get disconnected and Sensus would say connect compatible device (or something like that). Sometimes unplugging and plugging would work, other times not. Never had this issue with Android 8 device.

https://support.google.com/androidauto/answer/6348190#usb

*********
Check your USB cable
Not all USB cables will work with all cars. If you're having trouble connecting to Android Auto try using a high-quality USB cable.

Here are some tips to finding the best USB cable for Android Auto:

Use a cable that's under 6ft long and avoid using cable extensions.
Make sure your cable has the USB icon .
If Android Auto used to work properly and no longer does, replacing your USB cable will likely fix this.
**********

Not sure Android cable needs to be manufacture certified. All Apple cables have to be Apple certified, if not, once an iOS updated, the old non-certified cable no long worked and showed the compatible device message even to charge only and force you to buy a $20 Apple OEM cable, until Apple licensed out the certificate to third parties and lighting cable price dropped a lot since then.
 

·
VOC / Connectivity Expert
Joined
·
698 Posts
I second the issue with cables. On my Nexus 6 and my Pixel 2 XL, I have had issues with crappy cables. You definitely get what you pay for and I have personally just used the stock cables which have proven very reliable.
 

·
Registered
Joined
·
10 Posts
I’ve come across this problem as well with a Samsung S10 using a 3rd party cable on a recent roadtrip. Sometimes reconnecting the cable works but when it doesn’t it seems to disabl/lock the USB port as I’ve tried connecting an iPhone with lighting cable to apply CarPlay and it shows a similar error. For me restarting the car fixed everything which is inconvenient when it happens in the middle of a roadtrip.

Haven’t noticed the problem with in town driving.
 

·
Registered
Joined
·
8,786 Posts
Discussion Starter · #9 ·
As I've already stated I was using the cable that came with the phone, so if the car can't deal with that there needs to be a fix. That cable works fine in every other location/situation. This is basic input/output folks and if the car can't deal with an occasional errant packet then the infotainment is deficient.
 

·
Registered
Joined
·
134 Posts
Were you using the second USB port by chance? I've noticed that the car's USB hub doesn't seem to have enough power to actually use both USB ports. If I let someone plug in their iPhone to the second USB port, after 10-15 minutes my Android Auto will give a connection error and no amount of reconnecting or restarting the phone will fix it, the only way to fix it is to restart the whole car. Pretty annoying, the second USB port is basically useless.
 

·
Registered
Joined
·
8,786 Posts
Discussion Starter · #12 ·
The second port, the one with the circle around it, is actually the port you are supposed to use with android auto.

Sent from my SM-G973U1 using Tapatalk
 

·
Registered
Joined
·
512 Posts
"Pretty annoying, the second USB port is basically useless.'
I connect a 32GB flash drive to the second USB port. It contains all my FLAC audio files
 
1 - 14 of 14 Posts
Top