SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 21 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
After an engine rebuild problem :
Car is not fast as before should i change tcv or anything i belive car does not hold boost strogly like before.

Should i change charge pipes ??
Or change tcv pipes or what ur help is really apreciated.
 

·
Registered
Joined
·
1,242 Posts
I would check boost lines, CBV, and TCV.
 

·
Registered
Joined
·
233 Posts
Boost gauge would help a lot. Did you do a compression test after the rebuild? New or old CBV? Just a few things to look at in addition to what the others are saying.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #7 ·
Boost gauge would help a lot. Did you do a compression test after the rebuild? New or old CBV? Just a few things to look at in addition to what the others are saying.
Compression test no i did not do and cbv old ?? Should i change it or what ??

Sometimes the car doesnt start right away i should do it twice to start the car...spar plugs are new should i change ignition coils ????
 

·
Registered
Joined
·
1,242 Posts
What about timing?
 

·
Registered
Joined
·
4,272 Posts
Can you check what psi your wastgate is opening at? if tyou disconnect the elictrical from yout TCV does that make a difference? If not your TCV is not working
 

·
Registered
Joined
·
4,740 Posts
All the suggestions here are a waste if he didn't do a compression test.

You guys don't know the compression numbers, you don't know how many miles he's put on the car since the rebuild, you don't know if the rings have had time to settle in, you don't know what he used as oil to break in the engine. You don't know how he broke the engine in. He doesn't have any boost gauge to give us any boost levels. You're not understanding that he's using a higher 9.0:1 compression instead of a 8.5:1 compression. He's using a T2 engine instead of a T4 engine.

How could ever start handing out trouble shooting info without any basic info?

Ahzazou, I know you're strapped for cash, but you have to complete that compression test.
 

·
Registered
Joined
·
4,272 Posts
I specifically asked him if engine was rebuilt or replaced, he said rebuilt. I do agree with the need for a comprtession test, but checkign the WG adjustment & TCV functionality are both free and easy
 

·
Registered
Joined
·
233 Posts
Compression tester from AutoZone = free. Just a deposit. And its easy to do on this engine..
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #14 ·
All the suggestions here are a waste if he didn't do a compression test.

You guys don't know the compression numbers, you don't know how many miles he's put on the car since the rebuild, you don't know if the rings have had time to settle in, you don't know what he used as oil to break in the engine. You don't know how he broke the engine in. He doesn't have any boost gauge to give us any boost levels. You're not understanding that he's using a higher 9.0:1 compression instead of a 8.5:1 compression. He's using a T2 engine instead of a T4 engine.

How could ever start handing out trouble shooting info without any basic info?

Ahzazou, I know you're strapped for cash, but you have to complete that compression test.
I using B5254T4 engine with totally new internals , New Pistons all D shapped from volvo , New connecting Rods , New Big End bearing (standard ) ,New Main Bearing new Spark plugs , New Cylinder Head ,New Intake Valves , New Exhaustion valves , new springs new lifts, new Timing Built Kit .

I used the engine in the first 1000 Km under 2500 Rpm after that i changed oil and oil filter now i passed 2000 km yesterday and recently started to test the acceleration and trying to see the performance of the new engine after the rebuild , i Use 5 - 30 Synthic oil.

For your information all Parts in the engine OEM Volvo Genuine .

the car sometimes pulls like rocket , after a long drive i see car is too fast but sometimes i feel like hesitation sometimes not .

i am suspecting TCV after the car got stopped for 3 months till i got the parts from Tasca :eek:

what numbers should i get for the engine compression test after this explanation.

Car has Evolve tune stage 1 , Exaughst system for Evolve.
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #15 ·
Can you check what psi your wastgate is opening at? if tyou disconnect the elictrical from yout TCV does that make a difference? If not your TCV is not working
i have already bought the boost gauge it should be arriving soon. that would ease the troubleshooting process.
 

·
Registered
Joined
·
4,740 Posts
ahzazou, watch this:

 

·
Registered
Joined
·
4,740 Posts
I using B5254T4 engine with totally new internals , New Pistons all D shapped from volvo , New connecting Rods , New Big End bearing (standard ) ,New Main Bearing new Spark plugs , New Cylinder Head ,New Intake Valves , New Exhaustion valves , new springs new lifts, new Timing Built Kit .

what numbers should i get for the engine compression test after this explanation.

Car has Evolve tune stage 1 , Exaughst system for Evolve.
You should see 160-200. 200 is the best.

You stated using a T2 engine in this thread: http://forums.swedespeed.com/showthread.php?179631-Turbo-Boost-build-so-late-at-5000-RPM
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #18 · (Edited)
You should see 160-200. 200 is the best.

You stated using a T2 engine in this thread: http://forums.swedespeed.com/showthread.php?179631-Turbo-Boost-build-so-late-at-5000-RPM
I had installed that engine for a week then that engine blown because it was too bad engine after using for a week it was blown ... Then i had no choice so i bought a new internals for my t4 engine and got back to default setting ... I had really rough time fixing this car ... I believe with swapping engines the car alternator got affected sometimes i get messages about electrical power system urgent service !!!!

I am afraid that i made the wrong decition to fix the engine i spent more than 7000$ to fix it
 

·
Registered
Joined
·
861 Posts
I had installed that engine for a week then that engine blown because it was too bad engine after using for a week it was blown ... Then i had no choice so i bought a new internals for my t4 engine and got back to default setting ... I had really rough time fixing this car ... I believe with swapping engines the car alternator got affected sometimes i get messages about electrical power system urgent service !!!!

I am afraid that i made the wrong decition to fix the engine i spent more than 7000$ to fix it
There's minor differences between alternator voltage regulators on these cars.
http://forums.swedespeed.com/showthread.php?154493-Urgent-Power-System-Service-Message-AFTER-installing-new-Alternator&highlight=alternator
 

·
Registered
Joined
·
4,740 Posts
ahzazou, did you use synthetic when you broke the engine in or did you use convential oil then switch over to synthetic after 1000k?
 
1 - 20 of 21 Posts
Top