SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter · #1 ·
I have a 2013 S60. I purchased a used IAM 2.1 Level 3 NAV/DVD radio unit.
I installed said unit, as I have the NAV prep, 2 extra cables. The unit was working great (haven't gone to dealer to activate the NAV), basically just as my old radio was.

I went to put in a DVD and it accepted the DVD into the unit, but now doesn't act like I did.
Eject button doesn't work, it never said "reading disc" or even gives an "unreadable disc" error. If I select Media and then DVD/CD nothing happens, doesn't let me select it.

And now when I start the car, I get a black screen with the climate control info on bottom row and about 5 minutes later the rest of the screen (media/radio) info comes on.
This doesn't seem like it's just a "needing to be programmed" by dealer issue.

Can anyone agree or disagree? I can't imagine eject would not work unless programmed?
If it is, I'll pull the radio and try to get the disc out manually and then go get it programmed.

I just want to know if I need to return this radio and find another?

Thanks!!
 

·
Registered
Joined
·
603 Posts
same issue on 2016. Even if I use a USB stick, the option was not activated so I cannot update...
Thus, I think you have the same issue and by default, the system ask you to go to see your dealership
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #3 ·
the same issue of not being able to eject a disk? or are you trying to play a video file through the USB port in the console?

Just seems odd that I would have to now go to the dealership to eject a disk?
 

·
Registered
Joined
·
43 Posts
Discussion Starter · #4 ·
Well I got a refund for the radio and was told to just keep it. Guess I'll see if I can fix the DVD part of it and wind up with a free NAV/DVD unit upgrade.
 
1 - 4 of 4 Posts
Top