SwedeSpeed - Volvo Performance Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #1 ·
Out of the blue I got a "ABS/Anti-skid service required" and "Brake assist service required." Searched enough to know that it could be many things and I have ordered a VIDA/DICE to find out what the codes are, but unfortunately they shipped it via the China Post before I had a chance to upgrade shipping (should've waited to pay...) so its two to four weeks out. Annoying, I can't wait to fix whatever it is.

Anyone know where the BCM is? Figured I'd at least check the connections or something while I wait. Sure hope the BCM is not the issue; I understand they're expensive.
 

·
Registered
Joined
·
1,242 Posts
I have seen that those messages are usually for the accelerometers, wheel speed sensors. But you won't know until you check it though.
 

·
Registered
Joined
·
1,407 Posts
Brake assist service shows for the pedal position sensor on booster and also for the EBA/DSTC self-apply solenoid or pedal depression switch.
BCM is below the fuse box on driver's side in engine compartment. I have never seen the connector on Mark 25 Teves BCM give an issue unless it wasn't latched. That shows up immediately.
 

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #4 ·
Thanks guys. I did pull out the brake pedal position switch, but without cracking it open I could do little more than check the rod's travel, & put it back. Figured it couldn't hurt to try to disconnect the battery but I guess either the fault codes are not the type of memory that is erased when power is interupted or its not an intermittent fault. Looks liike I'm pretty much stuck until I'm able to scan it.

Weird, out of the blue (car has been otherwise rock solid), and only a couple weeks after listing the car for sale. But I haven't got a single inquiry yet and I'm having second thoughts about selling... just ordered an OBX DP, thinking about a DIY FMIC and a tune. Have nearly 30K on the ATF & have never changed the angle gear oil (just periodic check for leaks), so will also look at doing that.
 

·
Registered
Joined
·
309 Posts
I had the same thing....it references to a failure in an electronic part in the steering wheel column...
There is a volvo service bulletin that the dealers should have. My guys knew exactly what the problem was when i took it in....
 

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #6 ·
^^^ I'm guessing the clock spring?
 

·
Registered
Joined
·
1,075 Posts
Out of the blue I got a "ABS/Anti-skid service required" and "Brake assist service required." Searched enough to know that it could be many things and I have ordered a VIDA/DICE to find out what the codes are, but unfortunately they shipped it via the China Post before I had a chance to upgrade shipping (should've waited to pay...) so its two to four weeks out. Annoying, I can't wait to fix whatever it is.

Anyone know where the BCM is? Figured I'd at least check the connections or something while I wait. Sure hope the BCM is not the issue; I understand they're expensive.
You must think vida/dice is easy to install? lol.

just ordered an OBX DP, thinking about a DIY FMIC and a tune. Have nearly 30K on the ATF & have never changed the angle gear oil (just periodic check for leaks), so will also look at doing that.
if you do sell, what would replace it? would it be as fun to drive?
btw-obx and fmic and tune and snaab intake and kn filter would make this car a real fun to drive car. :p
 

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #8 ·
You must think vida/dice is easy to install? lol.



if you do sell, what would replace it? would it be as fun to drive?
btw-obx and fmic and tune and snaab intake and kn filter would make this car a real fun to drive car. :p
Kind of dreading the install actually; I am NOT a computer guy. Crap thing is my laptop is running Win7 Home Premium which apparently can't do XP mode. I have access to a desktop with XP SP3 on it so worst case I can drag it out to the garage, but would greatly prefer digging up a copy of XP to install on VMware on my laptop. We'll see, but having to wait 2-4 weeks to find out whether I can figure it out is generating some anxiety...

As far as replacements, I love droptops and miss owning one--replacement would be a low mile S4 Cab with an M6. But over the last couple months there haven't been more than 1-2 suitable S4's nationwide at any given time, none even remotely local, and no bites on my car. Thing is I know I'd miss the R since its barely broken in (just under 77K as of this post), everything works properly, is in great shape, and a really comfy DD. I'd prefer to just add the S4 and not sell the R but that would be a little much on my plate--can't justify it. But as of this moment its not looking like the S4 will happen soon so odds are I will just keep DD'ing the R which is not a bad place to be...
 

·
Registered
Joined
·
41 Posts
It all depends on the Vida version used. In the 2012 version there is no need for XP mode...
Windows 7 not beeing the basic version should be sufficient...
 

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #10 ·
Its supposed to be 2012A, so I will first try a straight install & see what happens.

Failing that, searching around I see there is mention of some workarounds that allow installation on Win7 Home Premium, and some other tricks to get XP mode to work on the same. Not excited since some involve messing with the registry, but I guess I'll cross that bridge when I get to it. Otherwise, I may have to try a XP SP2 machine I have access to, or go over to dads and drag out the XP SP3 desktop and hope it has enough ram...

Tom Petty was right, the waiting is the hardest part
 

·
Registered
Joined
·
753 Posts
I have this message showed up as well.
Was driving the car normally.
Any update on this?
Thanks
 

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #12 · (Edited)
Not yet. I got VIDA/DICE in the mail on Monday, I spent the last couple evenings getting VIDA loaded on my PC.

Here are the details of my install.

Basically followed instructions in this post.

Still have yet to learn how to scan for codes, or even try the DICE unit. Since I have Win7 Home, Virtual PC is a trial version & I have 30 days with it. I don't see an upgrade from 7 Home to Pro, only to Ultimate for $140. Other option is to get a copy of XP Pro SP3 for like $70-80, and load it on to Oracle VM VirtualBox (freeware). I'm a bit wary though of starting from scratch with XP on VirtualBox since it takes several hours to get everything set up, and there seems to be no guarantee I won't run into some other issue. If the upgrade to Ultimate will allow me to keep the Virtual PC I already created, I might just go that way... IDK

Anyways, I will say that my cruise control works, and AWD works. Pressing the DTSC button doesn't register anything on the message center, but the little green LED on the button itself goes on and off. Occasionally when stopping I hear a clicking/ticking from the rear as if ABS is activating. I'm guessing its just one sensor somewhere that ate it or is a little out of whack, like a wheel speed sensor or clock spring.

Can't wait to get home and try the DICE unit, baby steps...
 

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #13 ·
I finally got the DICE unit working, scanned the car, got a few codes & started poking around. Ended up being a loose connector for the RF wheel speed sensor! Very happy not to have to buy parts, made sure the connector was good and tight & took a cruise. As soon as the sensors read over 10km/h the messages went away and now everything is hunky dory. Got to adjust DRL modes to boot, what an awesome tool (once it works that is).
 

·
Registered
Joined
·
753 Posts
Thanks for the info.
I will look into the sensor.
BTW, can you update the TCM/ SCM/DEM software with DICE too?
Thank you once again.
 

·
Registered
Joined
·
1,126 Posts
Discussion Starter · #15 ·
IIRC you can set the TCM into adaptive mode, and reset the fluid counter, not sure what else, or what options exist for the SCM or DEM, didn't look there. So far I've barely scratched the surface with VIDA...
 

·
Registered
Joined
·
1,407 Posts
Updates are all software downloads and require legit VIDA loaded with a purchased subscription. Then you likely need a legit DiCE. Copy DiCE units supposedly do not have the correct chip to take the latest firmware update and function as software loaders.
 
1 - 16 of 16 Posts
Top