SwedeSpeed - Volvo Performance Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello everyone - this is my first post here, but I've been lurking for some time!

I purchased an '05 S60R Automatic with about 85k miles on it about 6 months ago. I had a mechanic look it over pretty thoroughly immediately after the purchase - he noted that everything looked pretty good aside from the drive belt and the PCV system. According to him, the AWD system is functional and in good order, and the transmission shifts smoothly. So, based on the mechanic's advice my first repair was the drive belt (this was the entire kit which includes the water pump and another belt). A few months later I had the entire PCV system rebuilt as it was leaking a slight amount of oil on top of the engine cover. Both of these repairs were quite expensive, but the car really seems to drive well overall (aside from pulling slightly to the right with no hands on the wheel). I've only ever driven vehicles with 4-cylinder engines so this one pulls quite hard by comparison. I was especially impressed by how buttery-smooth it accelerates under moderate throttle; it's a luxurious kind of power that I'm not accustomed to.

Enough backstory - the real reason I'm posting here is to seek your advice regarding an odd noise I've been hearing under full-throttle. That's really the only time I can hear it; the car sounds perfect at all other times. I created a crude video with my smartphone to capture the noise - I'll try to get a better one later on with a GoPro, but I figured I'd post this one in the meantime.

Short, crude video


Thanks in advance for reading this - and for providing any advice you might have!
 
1 - 1 of 1 Posts
Top