SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter · #1 · (Edited)
My engine is freshly rebuilt with a bunch of things that should keep it pretty cool; an aluminum radiator, a high flow electric fan, and well it's brand friggin' new. But, the temp was reading SUPER hot. So at the shop, we looked at the back of the engine with the laser / IR temp gun and things were as they were supposed to be: 91° C / 200°F. So, the gauge must be bad.

Now the question: Shell out the $$$ for a new original style gas filled temp gauge that might also be not too accurate, or try something else. I tried something else.

I rolled the dice and figured that I could spend the $19 for one of these cheapo Equus electric temp gauges.

It took a few days to ship, and i probably could have found one at my local auto parts store, but whatever. It arrived this afternoon.

Thankfully, it came with the 5/8" - 18 adapter, so the sensor bolted right on.

I hooked up the sensor, the power and ground and tested it.

As I had hoped, everything ran right at the temp it should, just over 90° C / 200°F.

Now for the moment of truth: could I get this crappy little gauge to fit in the stock place and not look like I had done anything.

Step 1: I disconnected and removed the original temp sensor and then removed the gauge from the speedo cluster.

Step 2: CAREFULLY so as to not damage anything or lose any TINY ****ING SCREWS, I disassembled the original gauge and separated the inner workings from the face and cluster mount.

Step 3: I cursed a lot when I destroyed the original gauge needle trying to get it off to complete step 2.

Step 4: I removed the front glass (be careful, it will break) of the Equus gauge, took the screw off the back, and liberated the electric gauge from its plastic housing.

Step 5: Compared the height of the electric gauge guts to the old mechanical gauge guts. They were the exact same height to the mm.

Step 6: Victory Dance.

Step 7: Drill holes in the gauge face mounts to match the original face.

Step 8: mount the face to the gauge using the TINY ****ING SCREWS.

Note: when you liberate the gauge from the plastic housing, the electric connection tabs will come out. this is actually OK, as you need the gauge to sit flush on the old mounting plate. This brings us to the next step.

Step 9: mark holes to match position of the original needle and then to match the new gauge wiring on the original mounting plate. Drill holes for +12v, ground, and sensor.

Step 10: run the wires through the holes in the mounting plate,

Step 11: I used solder paste to secure the wires in the gauge and tiny dabs of epoxy outside to secure them / protect against shorting.

Step 12: It's a bit inelegant, but I cut apart the plastic housing so I could use the mounting hole that I took the one screw out of at disassembly to secure the new gauge to the original mounting plate.

Step 13: attach the needle to the face, approximate the "off position" (about 10° CCW of the lowest spot on the original gauge face). I also trimmed the gauge stop off. i kinda wanted to see the temp gauge snap into position when the ignition turns on.

Step 14: connect it all and then adjust the needle position before you start / warm the engine.

Tomorrow I will fit it back into the speedo cluster, after I can get to the model shop and buy some bright orange paint so the needle can match the original.


Needle with the ignition on, but engine cool


engine getting up to temp


Side view


Needle with the ignition off / disconnected


Side view with wiring


Back of original speedo cluster mount. You can see the positions for the wiring holes, as well as the bit from the plastic housing used to hold the new gauge to the original mounting plate.

$19 and 2 hours got me a more accurate temp sensor than the original. woohoo.
 

·
Premium Member
Joined
·
9,303 Posts
Very nice! I don't think I've ever seen the old Bourdon-tube style read high, usually they get pinched and stop reading at all. But your adaptation is great. I bet it would work in earlier models too - if you really want sticker shock check out what folks want to repair the ones on a 444.
 

·
Registered
Joined
·
7,618 Posts
Great job! I had the same thing planned but you beat me to it. Good to know it works.
 
1 - 4 of 4 Posts
Top