SwedeSpeed - Volvo Performance Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
11,628 Posts
Discussion Starter · #1 ·
Like the title says, my friend has a 1999 S70 GLT, automatic, with 100k miles.<p>His son left the dome light on and killed the battery.<p>After jump starting the car, the check engine light is on, along with the flashing up arrow. The car drives like its stuck in 3rd gear.<p>The battery was looking poor so he replaced it and left the car disconnected for about 40 minutes hoping to reset the computer. Still the same issues.<p><br>I pulled the following codes:<p>P0751 shift solenoid a performance or stuck off<p>P0605 internal control module read only memory (rom) error<p><br>So what do you guys think?
 

·
Registered
Joined
·
547 Posts
Re: A friends S70 is wonky after a jump start (850arrrsaylikepirate)

TCU- transmission control unit sounds like it has gone bad. More than likely a really lousy coincidence
 

·
Registered
Joined
·
450 Posts
Re: A friends S70 is wonky after a jump start (heavyiron)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>heavyiron</b> »</i></TD></TR><TR><TD CLASS="quote">TCU- transmission control unit sounds like it has gone bad. More than likely a really lousy coincidence</TD></TR></TABLE><p>... or a voltage spike from the jump ...
 

·
Registered
Joined
·
2,889 Posts
Re: A friends S70 is wonky after a jump start (t5mmmm)

Or someone hooking up cables backwards, but not coming clean about it... <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/rolleyes.gif" BORDER="0">
 

·
Registered
Joined
·
11,628 Posts
Discussion Starter · #5 ·
Re: A friends S70 is wonky after a jump start (BEJinFbk)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>BEJinFbk</b> »</i></TD></TR><TR><TD CLASS="quote">Or someone hooking up cables backwards, but not coming clean about it... <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/rolleyes.gif" BORDER="0"> </TD></TR></TABLE><p>I really doubt my friend hooked the cables up wrong, he knows a thing or two about cars. And if he did hook them up wrong he would have told me.<p> "<I>TCU- transmission control unit</I>" are these things hard to replace / expensive?
 

·
Registered
Joined
·
7,737 Posts
eBay
 

·
Registered
Joined
·
11,628 Posts
Discussion Starter · #7 ·
Re: (MadeInJapan)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>MadeInJapan</b> »</i></TD></TR><TR><TD CLASS="quote">eBay</TD></TR></TABLE><p>Thanks, I will look into it.
 

·
Registered
Joined
·
11,628 Posts
Discussion Starter · #8 ·
Re: A friends S70 is wonky after a jump start (heavyiron)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>heavyiron</b> »</i></TD></TR><TR><TD CLASS="quote">TCU- transmission control unit sounds like it has gone bad. More than likely a really lousy coincidence</TD></TR></TABLE><p>Ding Ding we have a winner! <p>The TCU was toast. Maybe the jump start fried it, or maybe it didn't but something happened which killed it.
 
1 - 8 of 8 Posts
Top