SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
51 Posts
Discussion Starter · #1 ·
02 S60 bought a year ago.

1) for the past 9 months, the blower motor randomly comes on even with the car off and the keys out. starting to happen more often lately. Is this the blower motor resister switch? anything else it could be?

2) driver side doesn't blow cold anymore. passenger side is cold. it did this last summer so I added more 134a and it started working on the driver side again. checked the other day and 134a is still full so I cant add anymore. Is there any other problems other than blend motors that it could be?

I just purchased a new (used) temp control unit and am waiting for it to get here.
I am going to do the zip tie thing tomorrow on the A/c clutch because there is 190k miles on my car and has the original compressor and clutch. Car has been so reliable!
 

·
Registered
Joined
·
1,141 Posts
1. this is normal after you had the ac on, its drying off the moisture..it says in the manual i believe

Passenger compartment blower
Approximately 50 minutes after the ignition is turned off, the blower may come on automatically, and
run for seven minutes, to remove condensation in the A/C evaporator.
source: http://www.volvoosad.com/Manuals/s60_2002.pdf

2. probably the evaporator going bad
 

·
Registered
Joined
·
51 Posts
Discussion Starter · #4 ·
zip tie thing worked on the compressor clutch! Got colder!
also, messed with the hot/cold switch and the left side started blowing cold again. must be a short in the non-auto temp control unit. i ordered a used auto temp control unit off of ebay.
 
1 - 4 of 4 Posts
Top