SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
113 Posts
Discussion Starter · #1 ·
Wife's car bought used last year. When you run the A/C it blows cold for only like 15 minutes then starts blowing ambient temp air. I saw somewhere online someone having sililar problem. He solved it by taking out a couple of shims on the A/C Compressor Clutch. Does anyone have any other ideas on what I could check before I replace the Compressor? A temp. switch or something?

Or would someone have a link to that procedure on taking out the shims that they could post up for me?

Thanks!

Chris

98 V70 GLT
00 S70 N/A
84 BMW e30
85 VW Westy!
 

·
Registered
Joined
·
15,659 Posts
Re: A/C Problem, 2000 S70, N/A (unibagel)

Those symptoms could also suggest that you are low on refirgerant. As it's Earth Day, the correct thing to do is to have the system evacuated and recharged with the proper amount of refrigerant and a dye added. You could also just go to WalMart and get a can of refrigerant and a pressure gauge and follow the instructions. I have also read of the high temp switch problem but don't know about the shims.
 

·
Registered
Joined
·
15,659 Posts
Re: A/C Problem, 2000 S70, N/A (unibagel)

No- search this site and any of the volvo enthusiast sites- this site, volvospeed, matthewsvolvosite, brickboard, etc. and you should be able to read plenty about it.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top