SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3,457 Posts
Discussion Starter · #1 ·
Hey guys, <br>Long time no see <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0"><br>On my 99 S70 A/c went south. <b>The compessor or what ever it is clicks every 15 sec or so.</b> A/C blows warm air. I thought may be the system has a leak, so I collected the can to the port (next to ECU box) but the manometer on the can showed very high pressure,so I decide not to do anything. Does it sound familiar? I know nothing about A/C. I bought the car half in Feb, so I was not able to test it very well, but it was working..<p>Any ideas where to start?<br>Car has 109 kMiles if it's matter.<p><br>EDIT: 15 sec, not 15 min as I said before...<BR><BR>
<i>Modified by Papa_Kirlo at 10:28 PM 8-20-2009</i>
 

·
Registered
Joined
·
547 Posts
Re: A/C clicking and air doesn't get cold (Papa_Kirlo)

Are you sure you connected to the port with the BLUE cap? Red cap is high pressure side Blue cap is low pressure. If it was the blue, It could be clutch assembly. Are you getting any flashing red lights on the HVAC system when you first start the car? If so, get your climate control codes read.
 

·
Registered
Joined
·
3,457 Posts
Discussion Starter · #3 ·
Re: A/C clicking and air doesn't get cold (heavyiron)

The cap is black. I'll check later if it has any paint on it. But I'm pretty much sure this is the same port I used on my 98. It's located next to ECU box, beside pass side headlight. Nothing flashes on the HVAC, never seen this actually...<p> Clutch assembly (if what it is) - is this DIY job or not? <br>
 

·
Registered
Joined
·
63,543 Posts
Re: A/C clicking and air doesn't get cold (Papa_Kirlo)

If you think it may be the compressor clutch, yes there is an easy DYI over on Matthews forum but make sure you are filled up first.<br>The correct way is to evac the system and charge.<br>If you have a friendly mechanic it shouldn't cost more than 50-60 bucks
 

·
Registered
Joined
·
3,457 Posts
Discussion Starter · #5 ·
Re: A/C clicking and air doesn't get cold (JRL)

I just realized that in OP I said 15 min, I mean 15 sec ...
 

·
Registered
Joined
·
63,543 Posts
Re: A/C clicking and air doesn't get cold (Papa_Kirlo)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Papa_Kirlo</b> »</i></TD></TR><TR><TD CLASS="quote">I just realized that in OP I said 15 min, I mean 15 sec ... </TD></TR></TABLE><br>You're out of freon (134)
 

·
Registered
Joined
·
3,457 Posts
Discussion Starter · #7 ·
Re: A/C clicking and air doesn't get cold (JRL)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>JRL</b> »</i></TD></TR><TR><TD CLASS="quote"><br>You're out of freon (134)</TD></TR></TABLE><p>then why the manometer on the can shows High pressure in the system? <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/confused.gif" BORDER="0"> <br>I connected the refill can to the system and with can valve closed manometer showed High pressure. I did it twice resetting the gauge every time...
 

·
Registered
Joined
·
2,969 Posts
Re: A/C clicking and air doesn't get cold (Papa_Kirlo)

Compressor clicking on and off is a classic sign of low freon FWIW.
 

·
Registered
Joined
·
884 Posts
Re: A/C clicking and air doesn't get cold (Papa_Kirlo)

when your filling the system make sure that you have the a/c as cold as can be and also to have it on high and recirculate so that its workin its butt off. Then you go through an fill it mine does the same thing and i think i fly through freon because i tend to fill it 2x a summer min and about 1 every winter so mine might be on its way out. first id try the refil with everything on high and super cold then maybe the clutch fix
 
1 - 9 of 9 Posts
Top