SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just purchased this car a month ago and it runs like new and gets ridiculously good fuel mileage. It's a stick in a 'GT' model (didn't even know that existed until very recently). Really fun car. Only real issue is the AC is non-functional. Took it to a local shop and the tech there discovered that the charge is correct but the compressor simply won't engage. I was later told that there are 2 pressure switches, one on the high end and one on the low and I found them and jumped the one up by the firewall and nothing happened. Did the same on the lower one and the cooling fan engaged and the CEL came on. The compressor never engaged. Neither wire (there are 2) coming to the upper switch was 'hot' and it seems like one of them should be, no? One of three wires on the lower connector had a low voltage output and when I jumped it to the center wire the cooling fan came on and stayed on even after I removed my jumper wire. Nothing happened when I jumped the other wire. I don't think the compressor is getting any voltage to engage and my questions are: why not and where should it be coming from? Thanks in advance.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Re: (fcpgroton)

I have a code reader but one of the codes was a P1 something and it wasn't in my book so I have no clue what it was. I cleared the codes and they haven't returned, I'm assuming they appeared when I jumped the fan wire.
 

·
Registered
Joined
·
884 Posts
Re: (ylstaffer)

unless you have a volvo code reader i don think you can get the CC codes. I wish you could and if theres a way please tell me rather than bending over for the stealership (80$ to read the damn thing) Does your AC and recirc lights flash like 15 times when you start the car up? mine does it occasionally but my AC cycles a lot and i seem to fill it 2-3x a year and its always low
 
1 - 4 of 4 Posts
Top