SwedeSpeed - Volvo Performance Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
hey all<p>my roommate, who was previously unaware of the genius advice swedespeed had to offer, is having some trouble with his 850 turbo. its a 1995 sedan w/ 156k miles.<p>he explains:<p>"started when driving at higher speeds, i felt a thunk in the engine compartment after accelerating hard and the engine light came on immediately after.<br>there is now a rough, grinding feeling in the gas pedal especially when driving at 50-60mph. most noticeable around 50 and 60, eases up at higher and lower speeds speeds."<p>i tried to run through the search function, but had little luck. didn't know if there were any technical terms for what he was experiencing, though my ruminations led me to assume it was due to some stabilizing bushing tearing under the pressure of that acceleration he mentioned.<p>thanks in advance. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/embeer.gif" BORDER="0">
 

·
Registered
Joined
·
7,737 Posts
Did a turbo hose pop off and now the car is in limp mode? Did he even check under the hood in the engine compartment? We need more info in order to help on this one.
 

·
Registered
Joined
·
63,543 Posts
Re: '95 850, thunk and subsequent gas pedal grinding (feldman)

If he has a check engine light, tell him to get the code and come back to us
 

·
Registered
Joined
·
1,304 Posts
Re: '95 850, thunk and subsequent gas pedal grinding (feldman)

if a turbo hose did come off, most likely the air/fuel mixture would be ultra rich and the engine would stall almost immediately. most of time, u can't even start it
 

·
Registered
Joined
·
440 Posts
Upper motor mount cracked and loose? That would explain the clunk but not the CEL. More info. needed.
 
1 - 5 of 5 Posts
Top