SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
<U>Here is the problem:</U><br>Rough idle, like running on 3 cylinders.<p><U>Symptoms:</U><br>When unhooking the electrical connection to the injector nothing happens. (number 1 cly, if that makes any difference)<br>Even new Bosch injector, just put in today.<br>When unhooking the others, very noticeable difference.<br>Also idles for about 30 secs to minute then acts like all power cut off (1 sec duration) in park.<p><br><U>Here is what I know:</U><br>Have read the faq's several times on rough engine idle etc.<br>Cleaned the TBI (TBI cleaner)<br>Cleaned the AMS (TBI cleaner)<br>Replaced the air intake hose to turbo.<br>New spark plugs (ngk iridium)<br>There is good spark at the spark plugs.<br>New injector seals & 1 new injector (not sure I needed that now)<br>Timing right on the spot<br>No engine smoking<br>replaced vaccum lines<p><U>Questions:</U><br>Is there a relay/fuse for each injector some where?<br>Where is the main control for the injectors? Could that be bad on one cly?<br>Any other ideas???? <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/confused.gif" BORDER="0">
 

·
Registered
Joined
·
1,368 Posts
Re: 940 FI problem (keeper940tw)

Am amazed the car started even. IF you infact have a dead inj on NUMBER 1 all the time. Would lead thou to the other things you said about idles in park like crap and shuts off. HAS Inj on 1 for part time. No fuel in number one and the ignition cycle is going crazy running out of cycle with three cyls. And no number one in the game. Guess it is possible to start with NO number one fireing. But common wisdom and sense make for a stretch on that. Based on the fact that the firing order on any car starts with a 1? not a 2/3/4/5/6/7/8. So.......... unless your running backwards I have serious issues. <p>Firing order on a 2.3L I4 is 1-3-4-2 Clockwise as well.
 
1 - 2 of 2 Posts
Top