SwedeSpeed - Volvo Performance Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
430 Posts
Discussion Starter · #1 ·
I bought a code reader to see why my daughters glt keeps surging and stalling. It says speed sensor, after changing that part located at the fly wheel, the code comes back. Looking on Ebay there is also a speed sensor on the transmission also, the picture of that part has 2 bolt holes and I don't see any part like that on my trans...I do see a part labeled as a speed sensor at the back of the trans...can any body advise me where the 2 bolt one goes and if I should change both
 

·
Registered
Joined
·
1,002 Posts
The 850's have several transmissions, you need to check the SN to be sure. I just fixed a problem with my car getting speed to te cluster and not to the cruise & ECU and it was a bad wire off the cluster.
 

·
Registered
Joined
·
430 Posts
Discussion Starter · #3 ·
solution

The code reader said acceleration sensor...Not speed sensor...there are 2 locations for this. One is up under the plastic cowling near the wipers... the other possible location is down low on the cross member. It has rained alot around here and the cowl water vents were clogged on her car and the sensor was sitting in water...so the nos signal code...ordered a new one The one off a Hyndai is the same bosch code number and is only 13 bucks vs the almost 50 for the volvo one...hope this helps someone...the one on the cross member can be damaged by road trash and running up on curbs...
 
1 - 3 of 3 Posts
Top