SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
137 Posts
Discussion Starter · #1 ·
Well I took the car in for its 7500 and it went well. <p>I called and made my appt. and told them about the Rear View mirror rattling, my tailpipes were uneven and not to change the oil because Im on my own schedule. So they gave me a V70 loaner (rather nice one). So..the results:<p>1. Rattle.... ITS GONE! <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> They put felt tape between the rain sensor housing and windshield and then put Butyl tape on the rest of the "adjoining parts." No rattle, no noise! Sweet!<p>2. Tailpipes (I had told them I tried sliding the hangars back but that after one drive it just slides back to uneven). So they "adjusted brackets". Havent looked underneath yet... but they are much higher than they were and they are staying in place!! <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0"> Sweet!<p>Honestly I was going into this appointment with low expectations as far as results. But, they corrected my problems without giving me any BS. So I think the quality of service at my dealership is great.... I just wish they would be a little more liberal about customer parts and custom jobs. Anyways all in all a good trip to the service dept. I hope the quality continues!<p>Edit: I wanted to add also they had a new C70 out front when I pulled in and it had a huge sign in the windshield that said "iPOD READY!!!" ...... I shook my head.
 

·
Registered
Joined
·
651 Posts
Re: 7500k Service Report... it went well! (cbeerxx)

I have the uneven tailpipes too, and I took my car in, and the dealer said they "adjusted" them as much as possible, but there's no difference. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/frown.gif" BORDER="0"> I have 6600 miles on my car, only a few weeks until my first service <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/smile.gif" BORDER="0">
 

·
Registered
Joined
·
98 Posts
Re: 7500k Service Report... it went well! (cbeerxx)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>cbeerxx</b> »</i></TD></TR><TR><TD CLASS="quote">Well I took the car in for its 7500 and it went well. <p>Honestly I was going into this appointment with low expectations as far as results. But, they corrected my problems without giving me any BS. So I think the quality of service at my dealership is great.... I just wish they would be a little more liberal about customer parts and custom jobs. Anyways all in all a good trip to the service dept. I hope the quality continues!</TD></TR></TABLE><p>Who is your dealer? If they did a good job, tell the world and tell them!!
 
1 - 4 of 4 Posts
Top