SwedeSpeed - Volvo Performance Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
2,569 Posts
Discussion Starter · #1 ·
My 04 SR MT has been giving me some trouble lately.

It's a little tough to get it into 1st or 2nd gear (I unfortunately hit a pretty big pot hole last night and this got slightly worse). The others are fine, but when I come on and off the accelerator in 6th, the gear stick moves back and forth. Also, when I turn the engine off there's a bit of a shutter.

With 97K on it, I was thinking of changing the transmission fluid soon, so I'll probably do that ASAP, but I know next to nothing about any mounts. Can anyone point me in the right direction or give me any other suggestions?
 

·
Registered
Joined
·
1,242 Posts
A transmission flush, lower trans torques mount, upper engine mount would be a good start. Upgrading to the poly mounts helped my shifting become silky smooth.
 

·
Registered
Joined
·
2,418 Posts
Just consider (after changing mounts) if it does not improve, change the shifter cables. If you shift hard alot, they could definitely be worn. You be the judge.
 

·
Registered
Joined
·
844 Posts
check to see if the shifter cables are seated correctly. They both snap into a fork like barcket in the engine bay behind, and left of the air box.
 

·
Registered
Joined
·
5,397 Posts
Can a transmission Flush be beneficial for the 6mt? I've been getting mixed signals. My shifting lately has taken a turn for the worse. It really isn't going as smoothly as it should and I'm debating on whether I should just avoid the skeptics and just friggin' do it.
 

·
Registered
Joined
·
2,192 Posts
Can a transmission Flush be beneficial for the 6mt? I've been getting mixed signals. My shifting lately has taken a turn for the worse. It really isn't going as smoothly as it should and I'm debating on whether I should just avoid the skeptics and just friggin' do it.
Yes it made a huge difference for me. The polyurethane small and large transmission bushings also made a huge difference even though my IPD mount was in good shape.
 

·
Registered
Joined
·
5,397 Posts
Yes it made a huge difference for me. The polyurethane small and large transmission bushings also made a huge difference even though my IPD mount was in good shape.
I have all Poly's and for a time it worked great but now it's not so much.
 

·
Registered
Joined
·
942 Posts
Shifter cables could be toast. Increases the effort to shift...
Shifter bushings likely also worn out, get new ones...
 

·
Registered
Joined
·
2,569 Posts
Discussion Starter · #9 ·
Update: I replaced the Upper Engine Mount and Lower Trans Mount. The bushings on both (only small on the lower) were bad, but it didn't seem to help much.

Probably related: The engine shudders when I turn it off. Any other mounts that can easily be checked/replaced?

I just crossed over the 100K line this weekend and gave the R a nice double coat of wax. I'm planning on changing the transmission oil tomorrow after I take it back to the tire shop to have them loosen the wheel nuts that they over tightened waaaaay too much.
 

·
Registered
Joined
·
747 Posts
Make sure you use GL-4 fluid. GL-5 will make it worse.
 

·
Registered
Joined
·
4,001 Posts
check to see if the shifter cables are seated correctly. They both snap into a fork like barcket in the engine bay behind, and left of the air box.
this. also, it sounds like your shifter cables may need replacing. check motor mounts too if you get a ton of vibration when turning off motor (if it wasn't caused by stiffer upper mount and lower transmission mount poly bushings.
 

·
Registered
Joined
·
2,124 Posts
My 04 SR MT has been giving me some trouble lately.

The others are fine, but when I come on and off the accelerator in 6th, the gear stick moves back and forth.about any mounts. Can anyone point me in the right direction or give me any other suggestions?
Given the above, you are not fully in the shift detent, which means cable adjustment or replacement as has been suggested.

Changing fluid, mounts, etc., are all good things to do, but lever movement is a good indicator of partial engagement.
 

·
Registered
Joined
·
2,569 Posts
Discussion Starter · #13 ·
Thank you all for being very helpful to a young guy learning about his Volvo!

Here's (what I think) are the shifter cables:

<a href="http://s1171.photobucket.com/albums/r542/ESmith813/?action=view&current=IMAG1110.jpg" target="_blank"><img src="http://i1171.photobucket.com/albums/r542/ESmith813/IMAG1110.jpg" border="0" alt="Photobucket"></a>

and

<a href="http://s1171.photobucket.com/albums/r542/ESmith813/?action=view&current=IMAG1111.jpg" target="_blank"><img src="http://i1171.photobucket.com/albums/r542/ESmith813/IMAG1111.jpg" border="0" alt="Photobucket"></a>

I'm not sure what they're supposed to look like exactly, but I know that second one looks different from the first. Are those the bushings? Is there another thing/place I could check? Should I take this to an independent transmission shop or work harder to find an indy Volvo dealer and take it there?
 
1 - 13 of 13 Posts
Top