SwedeSpeed - Volvo Performance Forum banner
1 - 20 of 24 Posts

·
Registered
Joined
·
227 Posts
Discussion Starter · #1 ·
I hit a pot hole yesterday(Front Right), and every warning light on the car came on <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/eek.gif" BORDER="0"> <br>Chassis service required<br>Brake Failure Stop Safely<br>Limp Mode<br>ABS light<br>Check Engine Light<br>Brake Light<p>so..... I think a sensor or connection in the 4C came loose just wondering where to look.<br>Ive seen a diagram of where all of the sensors and modules are, but i cant find it now.
 

·
Registered
Joined
·
63,543 Posts
Re: 4C sensors and module diagram (Minn R)

You would not get all those lights if a sensor wire came loose, you would only get "<I>Chassis service required"</I><br>You must have some other issues along with that chassis error
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #3 ·
Re: 4C sensors and module diagram (JRL)

Ok <br>I'm at a loss. I went out, made sure all the sensor connections were tight in wheel well. Followed the wires into engine bay, and all of those connections were tight as well. <p>I pulled the two abs fuses and also a couple others.<p>When i turned the car back on. The only message displayed is the chassis service required.<p>All other lights and messages went away.<p> <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <IMG NAME="icon" SRC="http://www.vortexmediagroup.com/images/banghead.gif" BORDER="0"> <br>Any thoughts or ideas of what could have happened or what could be wrong still?
 

·
Registered
Joined
·
63,543 Posts
Re: 4C sensors and module diagram (Minn R)

If the sonsor itself is loose (not the wire) or got turned a bit, that will do it
 

·
Registered
Joined
·
55 Posts
same exact thing happened to me 2 weeks ago. i was takin a corner and my chasis light came on then after driving all my other lights came on and the cr went into limpmode. but when i shut the car off and turn it back on the chasis light is the only one thats on.<p>i scanned the codes in the sum and i had 10 codes, 6 of them were internal fault in the sum. so i went looking for the sum and found about a gallon of water under the ds seat. i pulled the seat out and the carpet and found the sum under water. took the sum apart and the circuit board was all coroded. the ac drain hose was off and filling my car up with water.
 

·
Registered
Joined
·
719 Posts
Re: (blackstage2)

I wonder if this is why my SUM module is shot? The dealer said it is showing errors. I need to look into this. where is that house you are referring to, because i have had a drop or two of water hit my foot while driving before from under the dash somewhere
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #9 ·
Re: (ClemsonS60R)

Thanks for the ideas. <p>Do you need to remove the front bumper to access the two accelerometers in the front of the car?<br>
 

·
Registered
Joined
·
2,071 Posts
Re: (Minn R)

yes you do, this is what mines looks like, sans zip tie would look nice, but it does the job <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/biggrin.gif" BORDER="0"> :<p><IMG SRC="http://i201.photobucket.com/albums/aa305/athruc/Volvo/IMG_6069.jpg" BORDER="0"><br><IMG SRC="http://i201.photobucket.com/albums/aa305/athruc/Volvo/IMG_6070.jpg" BORDER="0"><br><IMG SRC="http://i201.photobucket.com/albums/aa305/athruc/Volvo/IMG_6071.jpg" BORDER="0"><p>as you can see, that is what they look like and it needs to be leveled for the warning message to disappear. <IMG NAME="icon" SRC="http://********************/smile/emthup.gif" BORDER="0">
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #11 ·
Re: (QnsMostWanted)

Thanks <br>I'm going to have to check that. Ive been getting the chassis service light intermittently for a few months now. <p>I really don't want to take it in to the stealership because i am not under warranty any more. <IMG NAME="icon" SRC="http://www.vwvortex.com/vwbb/rolleyes.gif" BORDER="0">
 

·
Registered
Joined
·
658 Posts
Unfortunately it looks like you don't have any way of at least pulling chasis codes from your car. It would be a great investment to pick up one of those $200 dollar scanners that pull codes from all modules in our cars. Will save you chasing your tail around, plus not all codes will clear once you fix the problem. Alot of them require them to be manually cleared.
 

·
Registered
Joined
·
658 Posts
Sorry, just re-read your original post...<p>As you already know, 2 behind bumper, 1 at each front wheel clipped onto strut, 1 in trunk of car, forward of battery, one under passenger seat.<p>7/87 7/88 are under front bumper<br>7/89 is the one in the trunk<br>7/118 7/119 are the ones clipped onto the struts<br>7/120 7/121 are mechanical level sensors under the rear of the car<p>Can anyone tell me what the sensor is that's under the passenger seat? 7/164 is listed as a "DSTC pressure sensor" however it's not on the diagram at all.
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #17 ·
Re: (firehawk618)

Which scanner are you talking about? The obdII scanners?<br>I thought you needed vidas to get anything but the engine and emissions codes?<p>
 

·
Registered
Joined
·
4,740 Posts
Re: (Minn R)

<TABLE WIDTH="90%" CELLSPACING=0 CELLPADDING=0 ALIGN=CENTER><TR><TD><i>Quote, originally posted by <b>Minn R</b> »</i></TD></TR><TR><TD CLASS="quote"><br>I thought you needed vidas to get anything but the engine and emissions codes?<br></TD></TR></TABLE><p>Not true.
 

·
Registered
Joined
·
227 Posts
Discussion Starter · #19 ·
Re: (KillerB)

Which kind would you guys recommend to get?<br>Actron?<br>Innova?<br>Equus?<p>and which model would you suggest?<p>
 

·
Registered
Joined
·
55 Posts
i was using vides, im sure its a couple grand. i dont think any cheap obd2 scanner will work. ya it will prob communicate with the cel but thats not going to tell you anything. an update on mine is i cleaned all of the water out of the car and the sum.i used electrical cleaner on the circuit board and a tooth brush to clean it. its not fixed but instead of having 15 codes stored in dif modules i now have 4 codes in the sum and all the other lights have stayed off. guessing the sum is still bad
 
1 - 20 of 24 Posts
Top