SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter · #1 ·
Already searched the forum, didn't see this exact issue. Every other day or so when I put on the right turn blinker I get an error on the instrument cluster and the blinker isn't operating. Left blinker works fine. The problem comes and goes. I don't think it's a blinker mechanism issue because the lane keeping aid icon changes from white to yellow like it's knows I'm changing lanes regardless of whether the blinker works or not. Anyone else seen this?
 

·
Registered
Joined
·
226 Posts
I've had a similar incident where the turn indicator error message came up, then was in the messages section and then disappeared. This last time (it's happened twice in the +/- three years I've owned it) it seemed to precede a routine maintenance alert. The turn indicators have always worked as far as I can tell.
 

·
Registered
Joined
·
5,044 Posts
Bulletins are for dealers, not customers. Unless you pay for access to them. I assume you're under warranty? If so, take it in. It's a well known issue. If it has certain codes, the SWM is replaced.
 

·
Registered
Joined
·
226 Posts
I can confirm the above from member Tech. I had the intermittent turn indicator failure, which became more and more frequent as time went on. It seemed to occur only when indicating a right turn, though. The steering wheel module had to be replaced. I was not charged for the replacement.
 
1 - 6 of 6 Posts
Top