SwedeSpeed - Volvo Performance Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter · #1 ·
Started my S60 today and found the navigation screen to be totally blank, plus no radio or other features controlled by the center console. A/C and Defroster buttons light up with you push them, and they appear to work. Bliss button is lite up and appears to work. PA button lights up but doesn't work - probably because the nav screen + sound functions are out. No bluetooth, etc. Instrument cluster is fine.

Anyone else have this happen and any chance this is something simple like a fuse? Or would you this is likely to be something more involved......

Dealer is getting it in tomorrow and it's still under warranty. Is there anything I should be particularly looking out for when I hear back from the dealer?

This is one of the early T5 S60's fwiw....

TIA!
 

·
Registered
Joined
·
4,678 Posts
Do you have SENSUS 3.0 update? Sounds like it could be software related; you could also hold down the POWER button for a few seconds and it will RESTART(Reboot) the system. My brother and I used have some bugs like this before the 3.0 software update.
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #3 ·
Thanks for the suggestions PD007....Cannot get the system to restart. Tried various ways to do that as I was talking with my Service Adviser on the phone earlier today. Believe it's Sensus 3.0, am sure software check is in the cards among other things. Maybe will get lucky and some of my Bluetooth problems will get fixed when all is said and done!
 

·
Registered
Joined
·
23 Posts
Discussion Starter · #4 ·
How predictable..... on the way to drop off the car with the dealer, the Nav System et al magically came back on :facepalm:. Volvo logo appeared on the screen out of the blue and maybe 15 seconds later the system started to work. Went ahead and left the car, hopefully there's an error log of some kind that will shed some light on this.

Here's hoping this is not an intermittent problem that's difficult to diagnose.... Not sure whether I'm betting on it being hardware or software.
 

·
Super Moderator
Joined
·
39,289 Posts
There is a software patch that will take care of your issue. Tell your Volvo service people.
 

·
Registered
Joined
·
1,861 Posts
Really bad programming
Wow! Helpful post right there.

OP, as stated above this is a well known (and documented) issue - just go into the dealer, explain what happened, and a software patch will be uploaded that will solve the problem.
 

·
Registered
Joined
·
2,308 Posts
Wow! Helpful post right there.

OP, as stated above this is a well known (and documented) issue - just go into the dealer, explain what happened, and a software patch will be uploaded that will solve the problem.
He did answer the question, lol. I've found talking to your dealer only works with a savvy Service Adviser. What would be more helpful on this forum are actual parts numbers for software updates relating to the OP problems.
 
1 - 9 of 9 Posts
Top