SwedeSpeed - Volvo Performance Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hey all,
Just thought I'd report on an issue that may be affecting more owners. Haven't seen this issue mentioned in the past.

Basically the car has suffered periodic battery issues, as we've needed to jump start it 3x in the past year. Volvo Service diagnosed and said that the Sirius satellite radio antenna was draining power even though we don't have (and never had) a subscription. They said Volvo was aware of the problem and working on a software patch. In the meantime, they put in a 'fiber optic loop' to bypass the antenna.

I figure there would be past reports of this if Volvo were indeed aware of the issue. Hope this helps. Please feel free to correct or corroborate.

Cheers!
 

·
Registered
Joined
·
626 Posts
Satellite radio antenna cables are not optical. It sounds like your problem was the sat radio module not powering off and they simply disconnected it. Therefore they needed to jumper the car's digital network to restore the loop and avoid error messages.

When I added my sub and amp I noted that 12v is live to the audio amp and tuners even when the ignition is off. This requires that each module be responsible for.shutting down based upon a software command. Therefore a software bug or a defective module could cause your battery problem. Let us know if the bypass fixed it for you.
 

·
Registered
Joined
·
1,448 Posts
Satellite radio antenna cables are not optical. It sounds like your problem was the sat radio module not powering off and they simply disconnected it. Therefore they needed to jumper the car's digital network to restore the loop and avoid error messages.

When I added my sub and amp I noted that 12v is live to the audio amp and tuners even when the ignition is off. This requires that each module be responsible for.shutting down based upon a software command. Therefore a software bug or a defective module could cause your battery problem. Let us know if the bypass fixed it for you.
Wow, and all this time I thought you were just a pretty face! :)
 

·
Registered
Joined
·
23 Posts
Satellite radio antenna cables are not optical. It sounds like your problem was the sat radio module not powering off and they simply disconnected it. Therefore they needed to jumper the car's digital network to restore the loop and avoid error messages.
that's pretty much exactly what we are doing. Funny story, had a customer come in and complain that their sat radio wasn't working since they had it serviced at another dealer. After thinking I had a problem w/ the sat module and pulling it out just to find the loop, I found the paper work from the other dealer explaining exactly what they did and how the sat radio would not work.... Read what you sign


Sent from my iPhone using Tapatalk
 
1 - 4 of 4 Posts
Top