SwedeSpeed - Volvo Performance Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi all, last Friday was the first real hot summer-ish day we've have in SE Michigan and come to find out there is a problem with my radiator fan. Bought the car in November so haven't had an issue until now. Was sitting in standstill traffic with the AC on high and had a "High engine temperature" warning come up. Fans weren't going when I pulled off, except for a short burst when I shut the car off. Sounds like it may be a faulty module which I cannot seem to find an OEM part number for. I found one on Amazon which claims to be a replacement but only has one review which is for a Jag. Has any tried any of these aftermarket modules and had any results? Or have a OEM part number I could follow up on?

Thanks bunches!

Sent from my SM-G975U1 using Tapatalk
 

·
Registered
Joined
·
1,407 Posts
You will very likely have a no CEL fault code for fan performance. The problem when fans do short cycles is either a fan motor with too much current draw or the module is faulty. Fan current checked directly (run to battery through ammeter) is 30-34A start for either and smaller runs 15A continuous and larger 16.5A. You can likely unplug the smaller fan and get by until you get parts.

There is OE, Gates, and a whole bunch of non branded ones sold through several sellers. I'm afraid the Gates ones are the same as those non-branded. Buy from someone that will stand behind it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
It seems like the fan 'works' at least for a short duration when the car turns off. And I've run a scan tool, there are no fault codes. From what I've read there is a specific module that controls when the fans turn on that can be fault. My guess is this is what is causing the issue, but I have been unable to find a part number for the module only, it seems to really only come as part of the fans. The part number for the module is kinda what I'm looking for here.

Sent from my SM-G975U1 using Tapatalk
 

·
Registered
Joined
·
1,407 Posts
31319380 but volvo no longer services it and now specifies whole fan assy 31686808
 

·
Registered
Joined
·
656 Posts

·
Registered
Joined
·
33 Posts
Right around 102k miles, this past winter, my 2010 T6 fan wouldn't shut off one night when we got home. Over the course of about a week, while I searched for a solution, I would disconnect one of the relay cables to the module to turn the fan motor anytime I had to take the car out, which was a pain, but not too bad.
I refused to buy a whole new assembly and ultimately replaced my defective module with a Gates which I THINK I bought at IDPUSA or FCPEuro (but it could have been from elsewhere)...Install took about an hour and the fan has worked great every since (I'm currently at 107k in southern Alabama, where the car really needs good cooling.
 
1 - 6 of 6 Posts
Top