SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I'm a fairly new owner of a 2009 Volvo C70 with 6 Spd. transmission and 170,000 miles on her. All has been well enough with minor repairs here and there, however...

The clutch and transmission were one of the features of the vehicle that felt nice. We own three vehicles within our household and their all manual transmissions.

Unfortunately, my wife got in after starting the C70 but didn't quite have it out of gear before releasing the clutch and it jerked forward and stalled it. Just a typical mishap that happens to all of us that may have multiple "sticks" and get the release wrong. Anyway, from this point, I have zero movement in forward or reverse gears. The clutch still has a good feel. The shift/gear selection also feels good. No visible leaks, but a very faint gear rub/grind...something that could sound like the spline gears are stripped.

I'm hoping to learn of any weak points of this transmission?
other unrelated possible issues that could cause this issue?
To determine how such a subtle action can cause this problem?

It's almost as if the vehicle is in "safe mode" and not allowing movement. Thank you in advance for all input, as I'm hoping to get the vehicle back on the road.

Thanks again.
 

·
Registered
Joined
·
1,395 Posts
2009 Volvo C70 w/ 6 spd. manual transmission - problems, help

I would check the cable from the shifter. Maybe it’s broken if not I would disassemble and assemble the shifter according to VIDA.


Sent from my iPhone using Tapatalk
 
1 - 2 of 2 Posts
Top