SwedeSpeed - Volvo Performance Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 ·
Hey guys, new C70 owner here.

Put in a full tank of 93 today, very full. Added STP system cleaner. It had been run on regular before. Drove it fairly hard for about 30 minutes. Started and stopped a couple of times.

Then brake system failure warning, pull over light came on a couple of times. Restarted, then went away.

Then got Reduced engine performance and engine system service required dash warnings.

Let it run for a while and when I went to restart it won't turn over or crank. All electrical functions work with key turned on.

Tried second key, nothing.


I can't find a similar thread or fix online, could someone give me any advice or what may be causing it and how to maybe fix it?
 

·
Registered
Joined
·
465 Posts
Scan for codes and see what's there...
 

·
Registered
Joined
·
465 Posts
Scanning with VIDA would be ideal. There could be so many possible reasons for your issues. A VIDA scan would point you in the right direction.
 

·
Registered
Joined
·
198 Posts
Sounds like some electrical connection specific to the engine doesn't work. Like spark plugs not getting any juice or something.
But as others already said a Vida, or even standard OBD2, scan should point you in the right direction.
 

·
Registered
Joined
·
1,591 Posts
how old is your battery? if it's 3 years or more, it may be a dead battery
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #7 ·
Would all of the electrical things such as windows, radio, seats, etc. still work if the battery was bad?

All it does not is make one quiet click when the key is turned but everything else works.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #8 ·
Just a resolution, in case anyone else later on finds this thread. It sat for a day then started right up in neutral and hasn't had any issue or thrown any codes since. Maybe it was just bad or too much gas, either way, it just went away and hasn't had any issues since.
 

·
Registered
Joined
·
1,396 Posts
Thanks for the info. I stop filling when it stops and don’t add anymore gas. I’m glad you got it worked out.


Sent from my iPhone using Tapatalk
 
1 - 9 of 9 Posts
Top