SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hi, just took a trip from Ct to Nj and noticed a loss of power, hesitation and really poor gas mileage. Usually get 28+ but now 20+. Seems to have just happened. Any ideas?
 

·
Registered
Joined
·
347 Posts
Diagnostic codes will have been generated. Have someone with a scanner look at the codes and explain them to you. A bad spark plug, fuel injector, or sensor could create this kind of performance problem.
 

·
Registered
Joined
·
462 Posts
Diagnostic codes will have been generated. Have someone with a scanner look at the codes and explain them to you. A bad spark plug, fuel injector, or sensor could create this kind of performance problem.
Wouldn't hurt to check the condition of the air filter as well since the OP is looking under the hood.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·
OK thanks. I'll have thecodes read. No CE light. Should have mentioned car has 117k and just had evap pump replaced.
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #5 ·
The ce light came on right after this post. The code that came up is p0171 system too lean bank 1. I cleaned the maf and now the light us out and car runs better. CE light went out on its own.
 

·
Registered
Joined
·
347 Posts
Great, you fixed it yourself. What did you find obstructing or interfering with the MAF? Fall means leaf debris every where.
 

·
Registered
Joined
·
462 Posts
The ce light came on right after this post. The code that came up is p0171 system too lean bank 1. I cleaned the maf and now the light us out and car runs better. CE light went out on its own.
FWIW: I would get that same code when I ran the K&N oiled performance air filter. Cleaned the MAF and the code, would return. Replaced the K&N filter with the stock paper pleated version and never saw a problem again. This car is "funny" about it's air filters.
 
1 - 7 of 7 Posts
Top