SwedeSpeed - Volvo Performance Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
114 Posts
Discussion Starter · #1 ·
Hi all,

Crazy weather helped me realize that my AC doesn't work as it should. Was over 80 degrees in NY yesterday and turned on AC, it only blows cold through the passenger vents, driver side vents blows warm? Anything to look for that would cause this?


Thanks

Tony
 

·
Registered
Joined
·
16,856 Posts
The vents actuate differently. The driver's side may be stuck. Scan with Vida? I think this is possible.
I had the same issue and the indy discovered that it was really a failing system overall. I had to get a new drier, condenser, etc., so I ended up getting a radiator and the hoses too, while he was in there.
 

·
Registered
Joined
·
2,621 Posts
Sounds like its low on Refrigerant. Very common that when low on Freon that one side is somewhat cold and the other is warmer. Usually accompanied by a hissing sound in dash while compressor is running.
 

·
Registered
Joined
·
114 Posts
Discussion Starter · #4 ·
Added Freon and thankfully all good. AC is colder that ever! Any reason why I needed to add, why/where the leak? This is my 4th Volvo and never had to add Freon, AC was always fully functional and cold.

Tony
 

·
Registered
Joined
·
6,918 Posts
Maybe there is tiny leak somewhere along the pipe. If it becomes not so cool again after some time then repair is needed. Add some R134a with leak detection addictive, and use a ultra violet light to check where leak is. Or find a garage to diagnose and fix it.

Fusion · Red · T8 · XC60
 

·
Registered
Joined
·
573 Posts
Yea, you'll likely find it will leak down again. I chased this around on my '06 last summer. AC wasn't cooling, so I had it topped off and they added UV dye. A month later no AC again, they found the dye at one of the pipes through the firewall that they fixed, no other leaks detected at that time. A month or so goes by, and once again no AC, this time they found a new leak at the condenser. Replaced that and so far so good, it works fine still 10 months later.

My '01 has never had refrigerant added since I bought it in '11. It's now getting to the point where its a little weak (it does still cool, just not as well as it did), might have it topped off.
 
1 - 7 of 7 Posts
Top