SwedeSpeed - Volvo Performance Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
Hello all,

New to the community, so please bear with me.

When I am on and off the throttle, there is a clunk coming from the front right of the car. My first thought is engine/trans mounts (more specifically trans, as it's coming from lower right under the passenger floor where they lay their feet. Any ideas? I don't have any suspension rattle of any kind and the 4C seems to be functional in every regard.

Thanks!
 

·
Registered
Joined
·
437 Posts
yep, sounds like engine mounts, check ALL of them, not just trans
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #4 ·
Will check all of them - thank you both! And Hounddogger... awesome 300k+ mile thread.. loving it. Take care and thanks again!
 

·
Registered
Joined
·
11 Posts
I had the same issue with my S60R. I replaced the axle bolts after doing engine and transmission mounts and end links. It was the axle bolts causing the clunking... make sure to get the bolts with the rubber insulator!
 

·
Registered
Joined
·
649 Posts
Start with axle bolts first.

Then passenger side motor mount. If those don't fix it, it could be any number of things. But those 2 are common "non-suspension" causes for front end noise. Let us know how it turns out.

And Welcome to SwedeSpeed!!!

EDIT: I can personally vouch for those axle bolts. I've used them myself on my 07VR. Fixed my popping noise!
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #7 ·
Caboose, thanks so much for the help, as well as everyone else on this thread. I've ordered a new set of bolts with the rubber "bushing" on the bolt from IPD. Let's hope it works..

Is it as simple as removing the center cap, pulling the bolt out, and replacing? I've seen some conflicting information.
 
1 - 7 of 7 Posts
Top