SwedeSpeed - Volvo Performance Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
just got the girlfriend a s60r for her birthday and i feel like there is somthing wrong with it. ill jump in take a buddy for a ride in it one day and it feels super fast. the next day ill take it out and it feels slow. just got back from a cruise and i would say 15 minutes into the drive 1st 2nd 3rd gear pull felt amazing. back roads staying out of boost for the most part and then just before we got home i would say 20-25 mins after the last time i really got into the throttle. i did another 2nd 3rd gear pull. this time it felt like a dog. i then let off the throttle and noticed it pulled harder as i let off.. so i tested this buy running 3rd gear up a hill. by feathering the throttle between wot and 1/2 the car would surge and pull like it did at the beginning of the ride. i run 91 oct and the car is bone stock. any suggestions?? im bringing the car back to the dealer on monday just thought maybe i would try a forum for help other than trying to deal with the dealer.

thanks
ben
 

·
Registered
Joined
·
4,640 Posts
Hi there Ben,

First of all welcome to the forum.

Secondly I wouldn't advise running 91 grade fuel in this car, you should really use 93 at a minimum for the best performance and mileage.

Third, there a few things that could be causing what you are describing, could be as simple as a boost leak in the charge pipes, replacing the Turbo Control Valve (TCV) for $60 or any number of things. Can you provide a bit more info on the car like mileage, any modifications.

Do you have a boost gauge installed in the car? If not I would do that sooner than later so you have an idea of what's actually going on with boost when it surges, loses power......

There is also a R specific section of this forum that might have all the answers you need, might want to check there too.

Let us know what the dealer says, any codes that come up too.

Good luck and have a good day,
Brandon
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
well thank you for the tips. the car has 60k miles. up in maine we dont have 93 oct :( so im stuck with 91. i have been reading into the tcv problems that these cars have. and i suspect that is my problem. i have a gauge im going to install tonight and see if its a boost problem. my question is... if i set a mbc to 14-15 psi can i run that in place of the tcv?? or should i replace with a hd tcv from ipd??

also i will be doing a boost leak test to make sure i dont have any hoses leaking as well... i really like how helpful the volvo community is. really seems like you meet the nicest people on a volvo forum. wish i could say that for other forums haha. but yea i will be testing the car tonight and ill post the results in the morning. ill wait to hear back on the mbc install before i attempt the replace the tcv with one.
 

·
Registered
Joined
·
4,640 Posts
No you can't eliminate the TCV, nor can you run a MBC. The engine management system, Bosch ME7, is very specific in it's management of boost production.

I'd say try swapping in a known good stock tcv from another turbo volvo if you have access to one. Or sure a new OEM or IPD TCV would be fine too. Worth a shot if your making low or erratic boost and no boost leaks.
 
1 - 4 of 4 Posts
Top