SwedeSpeed - Volvo Performance Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
I have noticed a very strange problem with my 2007 s60r. When I turn the car on after it rains, it emits a high-pitched whine. The whine sounds a lot like regular engine noise, except a lot higher. It goes up and down with the RPM. As I drive the car, it gets fainter and fainter until it goes away. Accelerating makes it go away faster and braking sometimes makes it come back. The first time I heard it, I thought that it was coming through the speakers, since I could not find a place in the car, where it was louder or quieter. I have heard about a problem, where the driveshaft rubs against the exhaust system after driving over cold water, but that isn't it. This is why:

1. I can still hear the sound when the car is standing still.
2. I can only hear the whine inside the car. I have never heard it from the outside both when it's standing and moving.
3. It starts about 5 seconds after I turn the engine on. If this was a mechanical problem, the noise would start at about the same time, as the engine.
4. It sounds like it's coming through the speaker system. The noise is the same throughout the car and there are no places where it's louder or softer. This could make it a wiring problem and not a mechanical problem.
5. It doesn't come back when I drive over puddles. It only happens after rain and when the car hadn't been used for several hours.

I bought my car pre-owned with about 98k miles. The only problems I know it still has are a minor oil leak and a steering column, which might need to be replaced in the next few years.

What's causing this problem? Is it a mechanical or electrical issue? Please help. I love my R and I don't want to mess it up even further.
 

·
Registered
Joined
·
2,545 Posts
Yeah, I see what you're saying re: rain squeal, that usually happens in heavy rain and it sounds like running your finger around the rim of a giant crystal glass. Does the whine change when you use door locks or turn on a/c fan? Not sure I've heard of another quirk of the R in regards to water.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #4 ·
It doesnt't change with the door locks but I haven't tried it with the a/c yet. I always keep my a/c on and next time it happens, I'll turn it off and see if it goes away.
 

·
Registered
Joined
·
136 Posts
Remove the resonator!!!!! and have a shop weld in a straight piece of pipe...should cost around 50 bucks at most. This will fix your issue.
 

·
Registered
Joined
·
3,387 Posts
1. I can still hear the sound when the car is standing still.
Hey everyone... doesn't that rule out rain squeal? Rain squeal only occurs when the car is moving (prop shaft is rotating) and the the resonator rubs against the prop shaft.


98k miles on the odometer...could it be a squealing belt?
Leaky steering... could it be power steering pump or low fluid level?
 

·
Registered
Joined
·
11,927 Posts
Hey everyone... doesn't that rule out rain squeal? Rain squeal only occurs when the car is moving (prop shaft is rotating) and the the resonator rubs against the prop shaft.
Yes. Rain squeal pitch varies with speed not RPM for this reason as well.
 

·
Registered
Joined
·
1,389 Posts
something in the belt drive system would be my guess. How long since you changed the belt or inspected the various components?

Honestly (just read the 98k part) I think I'd be going in hard and heavy for a timing belt replacement (assuming you haven't done so). In doing that, you should be replacing the drive belt (and probably tensioner as well) and be done with it. I imagine that's where it is.

One easy way to check is, with the engine running, use a squirt bottle and squirt some water on the belt, then listen for noise.

FWIW, the Taurus is doing the same trick right now, and it's definitely the belt. Just haven't gotten to change it yet, honestly, not worried about it breaking or anything, just annoying. -yes I have looked at it, it's fine for a bit until I do a real hardcore teardown on it.
 

·
Registered
Joined
·
701 Posts
really sounds like rain squeal!!
resonator delete?
do you still have your exhaust bracket of death on?
Thanks for uploading the video, I had the same issue and ill find a bracket to repair it or remove the resonator ! nice R , I do the same thing...
 

·
Registered
Joined
·
8,734 Posts
something in the belt drive system would be my guess. How long since you changed the belt or inspected the various components?

Honestly (just read the 98k part) I think I'd be going in hard and heavy for a timing belt replacement (assuming you haven't done so). In doing that, you should be replacing the drive belt (and probably tensioner as well) and be done with it. I imagine that's where it is.
.
My tensioner was failing at 10 years and 46k. Made a ringing noise on startup that would go away as it warmed up. We tell low mileage customers all the time, its not the belt you have to worry about it's the tensioner.
 
1 - 12 of 12 Posts
Top