SwedeSpeed - Volvo Performance Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hello All,

Purchased my 05 with a bad transmission, Replaced it myself and love it!
I found the bad CEM from water intrusion and had the great folks at Xemodex repair it.
Really starting to get the kinks worked out and now the final phase:

I have a few problems you may be able to help with.

1) No headlights. Nothing. Notta. Neither side.. Dash warning comes on; Low beam failure.
(HID BULBS) (Daytime LED's do come on & Daytime running lights.

Turn the knob on the headlight switch module and nothing. (best way to troubleshoot?)
No high beam obviously (same bulb)

2) Engine Fan runs continuously. As soon as the engine starts matter of fact. And runs non stop until a few minutes following key off.

3) Turn Signals & Cruise Control- If i plug in the cruise control switch, the turn signals stop working.
Reconnect the cruise control, neither turn signals nor cruise control function.

ARE THESE ITEMS CO- Related? Any feed back is much appreciated!!!!!!

Thanks, Christian
Indianapolis, Indiana
 

·
Registered
Joined
·
11 Posts
No advice for you but I am having exact same problems with my '05 V8. Low-beam-failure warning, and the turn signal is intermittent, however I removed it once and cleaned the electronics board thats in it and that seemed to solve the problem, it gets dirty. The Engine fan, how I understand it, runs when you turn off the car to get all moisture out of the engine or something of the sort so as to keep mood out? Anyhow, it is made to do that. I need to replace both headlights but afraid that I can only replace with the HID bulbs, which are around $100 a piece:(
 
1 - 2 of 2 Posts
Top